1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with wp-o-matic

Discussion in 'Blogging' started by the-animal, Sep 29, 2009.

  1. the-animal

    the-animal Registered Member

    Joined:
    Sep 13, 2009
    Messages:
    77
    Likes Received:
    25
    Hi there

    I am having 2 problems using this program

    First of all it is asking me about cahing images and make it writeable. so I can save images to my server so the site runs faster

    I tried to make a cache folder and make it writeable but that did not work, not sure what to do

    The second problem is I keep getting a error message

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 71 bytes) in /home/tekfouyo/public_html/wp-includes/plugin.php on line 302 ,dont know what means

    ps Myserver is with Bluehost and I run wp-supercache

    any answers welcome
     
  2. MachTurtle

    MachTurtle Newbie

    Joined:
    Sep 12, 2009
    Messages:
    41
    Likes Received:
    24
    well first off, have you tried reinstalling it?
     
  3. the-animal

    the-animal Registered Member

    Joined:
    Sep 13, 2009
    Messages:
    77
    Likes Received:
    25
    I have done it twice, same problems
     
  4. bagelman77

    bagelman77 Newbie

    Joined:
    Oct 11, 2008
    Messages:
    11
    Likes Received:
    1
    create a folder named "cache" and make sure it has write permissions on.
     
  5. MachTurtle

    MachTurtle Newbie

    Joined:
    Sep 12, 2009
    Messages:
    41
    Likes Received:
    24
    First issue sounds like it may be your host. I'm not certain though.

    Second issue sound like you need to increase your allocation of php memory. I believe the default is 32 mb, so you'll want to increase this, especially if you are running several plugins.

    do this:
    -open the wp-config.php file in your wp directory.

    -Add the following code to this file
    Code:
    define('WP_MEMORY_LIMIT', '64MB');
    -save file back to your server.

    in the above code, you can increase further than 64mb, just do it in increments of 8mb. You may need to contact your hosting service to do this if it doesn't work.

    give it a try, I hope this helps. :)
     
  6. the-animal

    the-animal Registered Member

    Joined:
    Sep 13, 2009
    Messages:
    77
    Likes Received:
    25
    my cahe is fixed , thx for that
    any help on other problem
     
  7. the-animal

    the-animal Registered Member

    Joined:
    Sep 13, 2009
    Messages:
    77
    Likes Received:
    25
    crap did not work, I will keep trying though

    thx for fast response
     
  8. MachTurtle

    MachTurtle Newbie

    Joined:
    Sep 12, 2009
    Messages:
    41
    Likes Received:
    24
    try deactivating and reactivating all your plugins, see if that helps.

    also did you check to see if that line was already in the file defining it? if so, change that to a higher number, and get rid of the line you added.
     
  9. the-animal

    the-animal Registered Member

    Joined:
    Sep 13, 2009
    Messages:
    77
    Likes Received:
    25
    my server has gone down, need to try again in morning

    I will get back to you
     
  10. nasgorkam

    nasgorkam Newbie

    Joined:
    Apr 8, 2009
    Messages:
    33
    Likes Received:
    144
    Occupation:
    web designer of hexno.com
    Location:
    j.town
    Here's the problem of almost all rss aggregator, when the plugins try to grab the feeds content and extract it, basically its analyze the content of the feed from the title, content, encoded content, img etc.

    • Use thumbnail to save images, dont save the actual size. The process will eat a lot of memory.
    • Try to increase the memory limit.
    • Dont use the related post with thumbnail plugins (mem/cpu sucker)
    • Wp-o-matic tends to have problem with supercache, supercache will try to cache the post when the first time the content is published, the saving feed item process is eat a lot of memory.
    I switched from wp-o-matic to autoblogged since god knows, autoblogged have more feature like saving the thumbnail only and configurable template and tags + yahoo auto tagging. Combine this with db cache, wp-super cache and widget cache. You'll get wonderful autoblog.

    May that help.
     
  11. popzzz

    popzzz Supreme Member

    Joined:
    Apr 12, 2009
    Messages:
    1,337
    Likes Received:
    13,700
    Location:
    Don't touch the REP!
    You stated in the OP you created cache and gave it permissions and
    didn't work so how/what did you do to fix the cache?

    HTH .... :cool2:

     
  12. the-animal

    the-animal Registered Member

    Joined:
    Sep 13, 2009
    Messages:
    77
    Likes Received:
    25
    well, I still cannot get this thing to work, probs with memmory. Back to drawing board, unless someone can please upload there working php file

    To popzz, I just reinstalled wp-o-matic, made a cache folder and made it writeable - seemed to work, go figure

    ps I think I may try autoblog and see if works
     
    • Thanks Thanks x 1
  13. kilaz

    kilaz Jr. VIP Jr. VIP

    Joined:
    Aug 15, 2009
    Messages:
    876
    Likes Received:
    382
    Home Page:
  14. muslickzz

    muslickzz Junior Member

    Joined:
    May 23, 2008
    Messages:
    109
    Likes Received:
    51
    Gender:
    Male
    Occupation:
    Burden
    Location:
    Up in your Grill...
    Yea, you have to increase the Memory limit in your php.ini file...

    keeping in mind not all hosting services allow this.

    -Mus
     
  15. the-animal

    the-animal Registered Member

    Joined:
    Sep 13, 2009
    Messages:
    77
    Likes Received:
    25
    **update** I love this forum
    thx to everyone for their advice

    I called my hosting company to increase the memory, now my plugin works