1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[PROBLEM] Piwik Not Showing Adwords Keyword Properly...

Discussion in 'Black Hat SEO' started by lostpassword, Aug 24, 2012.

  1. lostpassword

    lostpassword Junior Member

    Joined:
    Jul 19, 2012
    Messages:
    135
    Likes Received:
    199
    I set up the adwords campaign and it ran.
    But on piwik I can't see any real keyword in the keyword field.

    I only see visitor coming from google with keywords like this:
    http://mysite.tld
    http://mysite.tld/subdirectory

    These are obviously visitors from the campaign as there is no way to reach
    http://mysite.tld/subdirectory
    except clicking on my adwords ad.

    So did google disable the keywords feature in tracking?
     
  2. toptoptop

    toptoptop BANNED BANNED

    Joined:
    Dec 24, 2011
    Messages:
    567
    Likes Received:
    157
    What are the IPs?
    You most likely see bot visiting your ads.
    He some times visits with a "real" Useragent but from Google IP ranges. He comes with your URL as a keyword.
     
    • Thanks Thanks x 1
  3. lostpassword

    lostpassword Junior Member

    Joined:
    Jul 19, 2012
    Messages:
    135
    Likes Received:
    199
    The IP is 74.125.63.33, US, Chrome

    The referrer is google search

    So google still pass on the keywords to piwik and this is just a google bot checking?
     
  4. toptoptop

    toptoptop BANNED BANNED

    Joined:
    Dec 24, 2011
    Messages:
    567
    Likes Received:
    157
    That's google, see whois http://whois.domaintools.com/74.125.63.33
    It is very normal, every time you make any change into your campaign he will come and also at any random time he may visit your pages.
    That's done to prevent cloaking and things like that I guess.
     
    • Thanks Thanks x 1