1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

*PLZ HELP*So when install ecommerce cart I get error with one host but not hostgator.Why??

Discussion in 'BlackHat Lounge' started by MiLiTARYiV, Nov 7, 2010.

  1. MiLiTARYiV

    MiLiTARYiV Senior Member

    Joined:
    Jan 9, 2008
    Messages:
    959
    Likes Received:
    595
    Occupation:
    Webmaster
    Location:
    The Office
    So I'm trying to install a shopping cart software e commerce website om shared hosting. I uploaded it and set proper permissions to the folders and files it requires but I keep getting this message in the middle of install:


    """ERROR occurred while coping the files! Please check if the var/skins_repository/base/customer directory exists, has read permissions and the skins root directory has write permissions""""



    But I did set the permissions as required:

    config.local.php - read/write for all users (666)

    /catalog - read/write/execute for all users (777)

    /images (and all its subdirectories) - read/write/execute for all users (777)

    /skins - read/write/execute for all users (777)

    /var (and all its subdirectories) - read/write/execute for all users (777)


    Now I installed this with hostgator to test and it worked fine, so I'm sure it has to do with the hosting server settings or something.

    But, what could it be??

    The reply from hosting was:

    You need to change the permission to files 644 and folder 755 if you set a folder to 777 this will simply not work.

    Can somebody help?
     
    Last edited: Nov 7, 2010
  2. extremephp

    extremephp BANNED BANNED

    Joined:
    Oct 19, 2010
    Messages:
    1,293
    Likes Received:
    1,272
    First of all, Tell me if Var is the folder in the script or it is the sever configuration folder like Phpini?

    Confirm that! Reply here and i can help you out more!

    And i hate carts other than Opencart! Just a suggestion!
    ~ExP~
     
  3. MiLiTARYiV

    MiLiTARYiV Senior Member

    Joined:
    Jan 9, 2008
    Messages:
    959
    Likes Received:
    595
    Occupation:
    Webmaster
    Location:
    The Office
    uhm its in root... Its a folder apart of package/script.. So if my website is
    Code:
    w3.xxxx.cxm
    the var folder will be like
    Code:
    w3.xxxx.cxm/var
    .

    The install folder is
    Code:
    w3.xxxx.cxm/install
     
    Last edited: Nov 7, 2010
  4. extremephp

    extremephp BANNED BANNED

    Joined:
    Oct 19, 2010
    Messages:
    1,293
    Likes Received:
    1,272
    well, do this!

    Delete the uploaded files :)

    Reupload again,

    Point to yoursite/install

    Finish the installation, and finally chmod the secure files such as config files etc!They will be given in the readme!

    You are over worrying by chmodding those at the start itself! No one cares to do those!

    ~ExP~
     
  5. MiLiTARYiV

    MiLiTARYiV Senior Member

    Joined:
    Jan 9, 2008
    Messages:
    959
    Likes Received:
    595
    Occupation:
    Webmaster
    Location:
    The Office
    That is the thing. I can't finish the installation because of the permission error when it tries to installs
     
  6. extremephp

    extremephp BANNED BANNED

    Joined:
    Oct 19, 2010
    Messages:
    1,293
    Likes Received:
    1,272
    Can you go, manually check if the customer directory is chmodded with 777 ?

    ~ExP~
    Posted via Mobile Device
     
  7. Chronos

    Chronos Junior Member

    Joined:
    May 5, 2010
    Messages:
    126
    Likes Received:
    294
    I think the 777 problem is, you're not allowing certain files to read/write. You need to give them more permissions.
     
    Last edited: Nov 7, 2010
  8. SleepieGirl

    SleepieGirl Regular Member

    Joined:
    Mar 7, 2009
    Messages:
    439
    Likes Received:
    290
    Occupation:
    Need Custom Programs? Message Me!!!
    Location:
    TenDollarBlog.com
    are you supposed to chmod the directory and subfolders?
     
  9. MiLiTARYiV

    MiLiTARYiV Senior Member

    Joined:
    Jan 9, 2008
    Messages:
    959
    Likes Received:
    595
    Occupation:
    Webmaster
    Location:
    The Office
    Ofcourse , that was the first thing I tried to do. It is set to 777
     
  10. MiLiTARYiV

    MiLiTARYiV Senior Member

    Joined:
    Jan 9, 2008
    Messages:
    959
    Likes Received:
    595
    Occupation:
    Webmaster
    Location:
    The Office
    Yes as I stated I did exactly as script wanted me to do. Like I said I installed this plenty of times on other hosting but for some reason on the hosting I'm using now, I'm getting the error..

    update: They said it was because suphp was installed on server. they are setting up new server without suphp..
     
    Last edited: Nov 7, 2010