1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP pages not loading on centos 6 server?

Discussion in 'Web Hosting' started by ArmoredMedia, Nov 4, 2013.

  1. ArmoredMedia

    ArmoredMedia Junior Member

    Joined:
    Sep 29, 2013
    Messages:
    130
    Likes Received:
    39
    Occupation:
    http://travisingram.net/
    Location:
    Washington, U.S
    Home Page:
    So I recently got a VPS for hosting instead, but PHP pages appear blank.


    I have Gooogled the issue in so many different ways and honestly nothing is working correctly.




    Any help? The directory I am trying to access is http://travisingram.net/rgc it's the same exact page as http://link-x.us/


    I am using centos 6 64bit and I do have PHP/Apache/MySQL/PHPMYADMIN installed etc.




    Much help appreciated.
     
  2. Panther28

    Panther28 Elite Member

    Joined:
    May 2, 2010
    Messages:
    2,268
    Likes Received:
    3,405
    Occupation:
    Internet.
    Location:
    Internet.
    the linx-x site is suspended, and the link you posted works perfect without the /rgc, so you have nothing loaded in your /rgc folder.
     
    • Thanks Thanks x 1
  3. ArmoredMedia

    ArmoredMedia Junior Member

    Joined:
    Sep 29, 2013
    Messages:
    130
    Likes Received:
    39
    Occupation:
    http://travisingram.net/
    Location:
    Washington, U.S
    Home Page:
    I just realized that I dropped the link-x host lol. There are files in the RGC directory. http://puu.sh/58gqp.png
     
  4. Panther28

    Panther28 Elite Member

    Joined:
    May 2, 2010
    Messages:
    2,268
    Likes Received:
    3,405
    Occupation:
    Internet.
    Location:
    Internet.
    well whatever you just done, now shows test on that page, it didn't before.
     
    • Thanks Thanks x 1
  5. ArmoredMedia

    ArmoredMedia Junior Member

    Joined:
    Sep 29, 2013
    Messages:
    130
    Likes Received:
    39
    Occupation:
    http://travisingram.net/
    Location:
    Washington, U.S
    Home Page:
    Also posted this over at HF, a guy suggested a stackoverflow post.

    In the php index I seen this: http://puu.sh/58gP2.png Gonna install ioncube loader and see what happens.
     
  6. Panther28

    Panther28 Elite Member

    Joined:
    May 2, 2010
    Messages:
    2,268
    Likes Received:
    3,405
    Occupation:
    Internet.
    Location:
    Internet.
    ioncube won't make a difference, the problem is the permissions to read the directory, compare the permissions of the rgc and your wp-admin folder, what are your rgc permissions?
     
    • Thanks Thanks x 1
  7. ArmoredMedia

    ArmoredMedia Junior Member

    Joined:
    Sep 29, 2013
    Messages:
    130
    Likes Received:
    39
    Occupation:
    http://travisingram.net/
    Location:
    Washington, U.S
    Home Page:

    Derp, panther. It was the Ioncube loader, I know I didn't have Ioncube loader installed and if it said that it's needed to run the script, well ... Anyways thanks for attempting to help out with my issue Panther :)
     
  8. Panther28

    Panther28 Elite Member

    Joined:
    May 2, 2010
    Messages:
    2,268
    Likes Received:
    3,405
    Occupation:
    Internet.
    Location:
    Internet.
    cool, glad to hear you got it sorted, you didn't say that the script had actually said that! :)

    always like to hear when my assumptions are wrong.

    anyway, everything is loading fine now by the looks of it.
     
    • Thanks Thanks x 1
  9. RMX

    RMX Power Member

    Joined:
    Nov 16, 2009
    Messages:
    726
    Likes Received:
    389
    Occupation:
    Network Security Admin
    Location:
    London, UK
    Home Page:
    Glad you figured it out. The Apache logs are a good place to start when having problems like this one. If you checked the logs first hand, you'd know what's wrong immediately.
     
    • Thanks Thanks x 1
  10. ArmoredMedia

    ArmoredMedia Junior Member

    Joined:
    Sep 29, 2013
    Messages:
    130
    Likes Received:
    39
    Occupation:
    http://travisingram.net/
    Location:
    Washington, U.S
    Home Page:
    The issue was I could not find apache logs in any directory.