Nmap Help

Discussion in 'BlackHat Lounge' started by Snckr, Feb 23, 2014.

  1. Snckr

    Snckr BANNED BANNED

    Joined:
    Dec 27, 2013
    Messages:
    581
    Likes Received:
    383
    I'm running an IP scanner script on my OVH dedi, it scans IP's with port 3389 open.

    When I open the .bat file, it opens for a few seconds and closes by itself.

    It works on my Poweruphosting VPS, so idk why it wont work.

    Can anybody help over teamviewer? Thanks!
     
  2. Snckr

    Snckr BANNED BANNED

    Joined:
    Dec 27, 2013
    Messages:
    581
    Likes Received:
    383
    [​IMG]

    Is the error I'm getting.
    Thanks!
     
  3. Grizzy

    Grizzy Senior Member

    Joined:
    Nov 11, 2008
    Messages:
    919
    Likes Received:
    1,001
    Open up the nse script and make sure shortport is properly declared. I think the require statement needs to be explicitly declared as a variable (it's a lua thing).

    So:
    Code:
    local shortport = require('shortport')
    instead of just:
    Code:
    require "shortport"
    Then update your nmap database and go from there.
     
    • Thanks Thanks x 1
  4. Snckr

    Snckr BANNED BANNED

    Joined:
    Dec 27, 2013
    Messages:
    581
    Likes Received:
    383
    Thanks! Would I replace local with anything, or just replace like that?
     
  5. Grizzy

    Grizzy Senior Member

    Joined:
    Nov 11, 2008
    Messages:
    919
    Likes Received:
    1,001
    hey your welcome. And nope, just replace with exactly what I wrote above.

    Hope it helps!
     
    • Thanks Thanks x 1