1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New website on expired domain, posts are indexed but not even top 100?

Discussion in 'Black Hat SEO' started by spectrejoe, Dec 15, 2016.

  1. spectrejoe

    spectrejoe Jr. VIP Jr. VIP

    Joined:
    Sep 25, 2013
    Messages:
    2,105
    Likes Received:
    440
    Home Page:
    It's only a week old site but I've built dozens and I've never seen this happen before, I'm also a bit inexperienced with aged/expired domains.

    Main Keywords Difficulty:
    #1 - 1300 MS
    [​IMG]

    #2 - 2900 MS
    [​IMG]


    As you can see the difficulty is laughable, hell you could probably rank top 10 with onpage SEO alone. Yet my posts are indexed and they are not even top 100 after a whole week?

    Both posts are 1.3k+ words with ~1% keyword density to a maximum of 1.5% density. (Verified on SEOQuake)
     
  2. jamesjk1

    jamesjk1 Senior Member

    Joined:
    Nov 1, 2012
    Messages:
    1,053
    Likes Received:
    652
    Occupation:
    404
    Location:
    Undisclosed
    Does sound a little odd. Was the domain clean? Google does seem to be taking longer in some instances, as has been reported here recently. I dunno. Give it another week.
     
  3. beingink

    beingink Senior Member

    Joined:
    Sep 19, 2013
    Messages:
    1,015
    Likes Received:
    219
    Google is out of whack post update, content indexes then disappears, PBN links are not moving shit.. God only knows whats happening.
     
  4. spectrejoe

    spectrejoe Jr. VIP Jr. VIP

    Joined:
    Sep 25, 2013
    Messages:
    2,105
    Likes Received:
    440
    Home Page:
    Yea, it only had ~110 links alive when I purchased it, mainly purchased it because I liked the name + some of the links were pretty decent and the age (5 years old)