need help !!!

Discussion in 'White Hat SEO' started by stevelori, Sep 13, 2012.

  1. stevelori

    stevelori Newbie

    Joined:
    Oct 5, 2010
    Messages:
    40
    Likes Received:
    0
    hello friend
    i have an a amazon base site with about 3000 pages and about 400 hits a day alot of keyword in the number 1 place (the domain is 2 years the site 1 month old,no seo have been done )
    yesterday i wake up and the pages are still in google search engine
    but all the keywords and the enter number of users is 0 its like my pages its not rank on any keywords

    any one know what appen
    and is there any way to fix it
     
  2. eltito

    eltito Junior Member

    Joined:
    Oct 19, 2011
    Messages:
    168
    Likes Received:
    23
    Occupation:
    Too many things...
    Location:
    Spain
    Maybe Google Dance, hold on for two-three days and check the results.

    Enviado desde mi GT-S5830 usando Tapatalk 2
     
  3. john1444

    john1444 Jr. VIP Jr. VIP

    Joined:
    Mar 27, 2012
    Messages:
    2,612
    Likes Received:
    765
    Gender:
    Male
    Occupation:
    Graphic Designer & SEOer
    Location:
    Miami, FL
    Home Page:
    It could be as a result of the kinds of off page SEO you have done on it is now affecting it.
     
  4. Adam718

    Adam718 Senior Member

    Joined:
    Jun 19, 2012
    Messages:
    1,105
    Likes Received:
    484
    Occupation:
    Crypto Trader
    Location:
    NYC
    He said he's done no SEO for it. That's really weird. Did you buy this website from someone?
     
  5. MatthewWoodward

    MatthewWoodward Senior Member

    Joined:
    Aug 31, 2012
    Messages:
    992
    Likes Received:
    1,696
    Occupation:
    SEO
    Location:
    UK
    Home Page:
    Don't worry about it Google will throw those kind of fluctuations at you sometimes.

    I have sites I haven't touched for years that bounce up and down the rankings even dropping into the number 1 spot for a couple of days and then back out and then back in the 80's.

    No idea why, I have a fair amount of sites I've not touched for years that behave like that.