1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need advice, did domain 301 redirect and nothing happens

Discussion in 'White Hat SEO' started by UnDerDoG81, May 26, 2017.

  1. UnDerDoG81

    UnDerDoG81 Power Member

    Joined:
    Oct 29, 2009
    Messages:
    542
    Likes Received:
    82
    Hi, 4 weeks ago I did a 301 domain redirect. Im moved my ugly sounding domain to a new domain. The main keyword came quickly back on #30 (was #11 before) but about 10 days ago every single ranking/keyword dropped completely. I have almost no traffic anymore. I am not sure what I did wrong. I did the 301 in the Cpanel and everything is working fine. Should I go back to the old domain? Or wait another week?

    The move to the new domain was not 1:1. I changed some spammy urls from the old site on the new one and made them less spammy. Also I removed 3-4 urls completely. The site had about 20 pages in total. Maybe thats a reason? When I open the old url, I get a 404 on the new site. I redirected them now 3 days ago correctly with 301 to the new url but I guess it might be too late already?

    What I also see is, google has still indexed my old site. When I check the google cache, it shows the new domain. Is that not weird? Since it seems like it is duplicate content now? It has the old and the new domain in the index?

    Here in another thread people told me it will take max. 4 weeks until I get all rankings transfered to the new domain. Not one single keyword is ranking. I have a feeling that there is a bad ass penalty but am not sure why. I builded 2 strong (PBN) links to the new domain but that should not be the reason? Because the drop was before them 2 links.

    I was going to rebrand another site of mine and move to a new domain but after this desaster I am not sure anymore.
     
  2. vilto

    vilto Jr. VIP Jr. VIP

    Joined:
    Dec 4, 2016
    Messages:
    228
    Likes Received:
    39
    Gender:
    Male
    Hello,

    What is your website ?

    Did you try to use some tools to check if your redirections are good ? -> Screaming Frog
     
  3. UnDerDoG81

    UnDerDoG81 Power Member

    Joined:
    Oct 29, 2009
    Messages:
    542
    Likes Received:
    82
    Hi,

    yes the 301 works correctly. I am not sure what happened but all rankings came back 4 days ago. Still not at the same position where the old site was (#11 and now #16). I had mass 301´d all 404´s to the home page, maybe that was the reason for the penalty. I removed that, redirected old sites correctly to the new sites and few days later site started to get rankings back.