1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My site disappeared right after building some links. Normal?

Discussion in 'Black Hat SEO' started by zacatictac, May 27, 2015.

  1. zacatictac

    zacatictac Jr. VIP Jr. VIP

    Joined:
    May 2, 2010
    Messages:
    654
    Likes Received:
    767
    Occupation:
    SEO
    Location:
    Metaverse
    So I have a new site (week and a half old). Spent the last week or so stocking it up with some articles about 15 high quality optimized articles I wrote myself, then yesterday I had about 50 high PR web 2.0's built as some tier 1's (decent quality, mildly spun). Today when I check just about everything I had indexed has dropped completely out of view, not in the top 300. My question is did I fuck up by building link too early, or could this be just a google dance and they'll come back higher up. I know theirs know way to know for certain, but if you had to wager a guess what would you say?
     
  2. SimpleSiteSolutions

    SimpleSiteSolutions Jr. VIP Jr. VIP

    Joined:
    Oct 2, 2009
    Messages:
    640
    Likes Received:
    1,042
    Occupation:
    Your next writer
    Location:
    Canada
    Too early to tell in my opinion. I would not go from 0 to 50 web 2.0 links in 1 day though. Spread it out a bit and try to keep it relatively consistent
     
    • Thanks Thanks x 1
  3. jon_xx_x

    jon_xx_x Jr. VIP Jr. VIP

    Joined:
    Nov 15, 2008
    Messages:
    3,235
    Likes Received:
    1,496
    Probably google dance. Just keep building links, preferably higher quality ones and it should stabilize.
     
    • Thanks Thanks x 1
  4. jamesjk1

    jamesjk1 Senior Member

    Joined:
    Nov 1, 2012
    Messages:
    1,053
    Likes Received:
    652
    Occupation:
    404
    Location:
    Undisclosed
    Too early to panic yet. Give it some more time. Often will pop back up in a better position.
     
    • Thanks Thanks x 2
  5. zacatictac

    zacatictac Jr. VIP Jr. VIP

    Joined:
    May 2, 2010
    Messages:
    654
    Likes Received:
    767
    Occupation:
    SEO
    Location:
    Metaverse
    Ok thanks guys. I'll probably gt a high quality drip feed service going on it in a few days and some social signals and see how that works out. This site is sort of an experiment as I havn't tried to rank a site in quite a few years.
     
  6. Dj Co2

    Dj Co2 Elite Member

    Joined:
    Aug 21, 2009
    Messages:
    1,520
    Likes Received:
    2,358
    It's normal. Happens to me even when I'm drip feeding links.
     
  7. SYKing

    SYKing Jr. VIP Jr. VIP Premium Member

    Joined:
    Apr 22, 2010
    Messages:
    2,333
    Likes Received:
    370
    Occupation:
    Student
    I'm agree with above commenter, I wouldn't go with 0-50 web 2.0 in one day (using decent spun content) atleast not for new website. It may because of google dance, wait to have these web 2.0 indexed.
     
  8. jollyman

    jollyman Elite Member

    Joined:
    Aug 29, 2013
    Messages:
    1,816
    Likes Received:
    288
    Gender:
    Male
    Occupation:
    Digital marketing
    Location:
    Somewhere around BHW
    Yes, this happened because of more back links point towards your site . At the same time, build quality backlinks that can help in improving the crawl rate of website and regain its position back.