1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

More then half of my backlinks disappear on all sites?

Discussion in 'Link Building' started by wizzardz01, Nov 16, 2011.

  1. wizzardz01

    wizzardz01 Power Member

    Joined:
    Jan 7, 2010
    Messages:
    572
    Likes Received:
    337
    Occupation:
    Digital Marketing Director
    Location:
    Bosnia and Herzegovina
    Did anyone else notice missing of backlinks?

    whats happening, all my domains lose half or more backlinks today?
     
  2. volund

    volund Senior Member

    Joined:
    Jan 24, 2010
    Messages:
    1,158
    Likes Received:
    728
    Occupation:
    Trying to make a buck or two
    Location:
    NW Arkansas
    How are you checking them?

    Are they just not showing up in whatever tool you are using or are the links actually being deleted?

    What types of backlinks are we talking about?
     
  3. wizzardz01

    wizzardz01 Power Member

    Joined:
    Jan 7, 2010
    Messages:
    572
    Likes Received:
    337
    Occupation:
    Digital Marketing Director
    Location:
    Bosnia and Herzegovina
    I am using SeoQuake, siteexplorer.search.yahoo.com...
    And some other tools and all show half of my links...

    But all my sites have same position like yesterday its ok all, but not showing me all backlinks.

    Its all manual done backlinks, profile backlinks, forum signature, articles, web 2.0. etc... All white hat!
     
  4. wpbacklinks

    wpbacklinks Jr. VIP Jr. VIP Premium Member

    Joined:
    Mar 27, 2010
    Messages:
    3,397
    Likes Received:
    1,339
    Gender:
    Male
    Occupation:
    Affiliate Marketer
    Location:
    Everywhere
    Me too............. :batman: i don't care.. lol

    @OP, maybe your backlinks have been deleted or missing.. :D
     
  5. supapera

    supapera Regular Member

    Joined:
    Sep 12, 2010
    Messages:
    212
    Likes Received:
    132
    Occupation:
    rushing long
    Location:
    de_dust2
    same thing happened to me :O
     
  6. imlol

    imlol Regular Member

    Joined:
    Apr 21, 2010
    Messages:
    318
    Likes Received:
    464
    Location:
    USA
    I noticed that with one of my sites today. I check another and it had not changed. I thought that a lot of my links had been deindexed, not sure what happened. There was not change to its position.
     
  7. poweronics

    poweronics Jr. VIP Jr. VIP Premium Member

    Joined:
    May 1, 2011
    Messages:
    3,117
    Likes Received:
    353
    Occupation:
    Freelancer
    Home Page:
    This happens for different reasons.
    1-not submitting the back links properly
    2-submitting to sites, which do not support back linking.
    3- Some sites have policy of removing backlinks after a specific time period (e.g. free directories).
     
  8. Markthedude

    Markthedude Power Member

    Joined:
    Feb 26, 2010
    Messages:
    572
    Likes Received:
    266
    Occupation:
    Entrepreneur
    Location:
    United States
    I've been dealing with this same thing for one of my new sites, normally I have to backlink slowly over the first month so that I can really hammer out links after that without it looking unnatural to big G. I'm using SEOquake as well and so that might be the problem. I know that Yahoo SE is going away soon and maybe certain aspects of it have starting to get shut down.

    All I know is that 3 days after I started backlinking I had 20 links to my new domain, it's about 2-3 weeks out now and I have 4. I'm doing way more then I normally do to get the count up but this is the first time I've had this issue. I mean, the backlinks are disappearing as fast as I can make them and no, these are not crappy spammy links, these are high quality links, some I've purchased off BHW.

    Sidenote: What's a good alternative to Yahoo Site Explorer? I will not install any Google products though on my site so Webmaster Tools is out.

    I know Traffic Travis shows links but I believe that it use's the Yahoo SE API.
     
  9. wizzardz01

    wizzardz01 Power Member

    Joined:
    Jan 7, 2010
    Messages:
    572
    Likes Received:
    337
    Occupation:
    Digital Marketing Director
    Location:
    Bosnia and Herzegovina
    Not really i think its bug or it will be back, because first i don't spam backlinks, do it all manual and all is quality backlinks, i don't have thousands of backlinks!
    And they are not same for all sites ;)
    And also my sites is not all from same IP.
    And ofc, i didn't made all that backlinks in same time that suddenly today at all sites disappear.
     
  10. volund

    volund Senior Member

    Joined:
    Jan 24, 2010
    Messages:
    1,158
    Likes Received:
    728
    Occupation:
    Trying to make a buck or two
    Location:
    NW Arkansas

    Have you checked to see if your links are actually there?

    Most/All of these tools use YSE which has been officially discontinued. Because of this the results you get are going to be a lot less reliable than they were.