Major Sitemap issue?

ThaiDreamer

Regular Member
Joined
Apr 24, 2018
Messages
436
Reaction score
153
Hi all!

So you might have come across my journey thread and the ongoing problem with the indexation of my articles.

I'm still trying to sniff out the main cause of the issue and I think I have a major problem with my sitemap.

First of all, for a few months now, I've started receiving organic traffic with utm_source set to my RSS. So the link looks like this:

1a.png


ie. mydomain.com/best-x-for-y/ isn't indexed as just regular url but comes with the additional string with utm_source=rss & utm_medium=rss & utm_campaign=best-x-for-y.

Today I have around 20 pages like this, all added in the last few months (old pages are not affected).

3a.png


Pages like this are getting traffic but this is marked as "Other" and not "Organic Search" in Google Analytics.

Second of all, something weird is constantly happening with my Sitemap in Google Search Console.

The number of affected pages is 19 today but it was 118 just a few days ago - and I've done nothing to change it.

2a.png


In the Sitemaps section in GSC, everything seems normal:

4a.png


...but it's clearly not.

Can anyone relate/help me with how to fix this issue?

For your information, I'm using the Yoast SEO plugin.

Thanks a lot!
 

Roger Marquez

Jr. VIP
Jr. VIP
Joined
Apr 17, 2017
Messages
3,599
Reaction score
4,608
Website
bit.ly
Maybe these guides will help...


Cheers!
 

ThaiDreamer

Regular Member
Joined
Apr 24, 2018
Messages
436
Reaction score
153
Maybe these guides will help...


Cheers!

Hi mate, thanks for the reply.

I understand how UTMs work and I don't mind it per se. I just think that it shouldn't be there and I think the whole issue around sitemap might be related to my indexation problem.

Can anyone suggest anything else here? How to fix this? Maybe I should move away from Yoast and try something else? How to transfer it safely so I don't screw up my site?

Thanks!
 
Top