1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Indexed...but gone from SERPs?

Discussion in 'White Hat SEO' started by 6000RWHP, Sep 23, 2011.

  1. 6000RWHP

    6000RWHP Regular Member

    Joined:
    Nov 13, 2009
    Messages:
    240
    Likes Received:
    108
    I converted a static site to wordpress. The naming structure changed (ie, no .html on the pages) so I did a 401 redirect.

    Everything disappeared from the SERPs.

    So I went back to the old .html naming structure.

    Now, when I google the actual URLs, Google will list them. But for any search..EVEN if I search the actual titel..the pages are GONE.

    Made a site map and submitted via google webmaster tools...twice. But my pages never appear in the serps???
     
  2. GangsterProfit

    GangsterProfit Junior Member

    Joined:
    Aug 26, 2011
    Messages:
    193
    Likes Received:
    69
    Home Page:
    I assume you mean 301 redirect? If you're using a 401 that could be your problem.
     
  3. 6000RWHP

    6000RWHP Regular Member

    Joined:
    Nov 13, 2009
    Messages:
    240
    Likes Received:
    108
    sorry...301 redirect
     
  4. GangsterProfit

    GangsterProfit Junior Member

    Joined:
    Aug 26, 2011
    Messages:
    193
    Likes Received:
    69
    Home Page:
    Have you checked to make sure the 301s are working correctly? No issues with robots.txt? What do you mean when you say you went back to the old .html naming structure, how was that accomplished?

    There's gotta be an obvious issue here...
     
  5. Joeblack99

    Joeblack99 Newbie

    Joined:
    Mar 31, 2009
    Messages:
    37
    Likes Received:
    20
    Redirects are definitely the most likely culprit here. I don't know much more than that unfortunately but analyse them and correct/remove them I reckon.
     
  6. 6000RWHP

    6000RWHP Regular Member

    Joined:
    Nov 13, 2009
    Messages:
    240
    Likes Received:
    108
    The redirects were done w/ a wordpress plugin. That plugin is now disabled.

    robots.txt says:
    User-agent: *
    Disallow: /cgi-bin/