1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

iMacros G+ Follow Button

Discussion in 'Other Scripting Languages' started by Scorpion Ghost, Aug 17, 2015.

  1. Scorpion Ghost

    Scorpion Ghost Senior Member

    Joined:
    Mar 22, 2013
    Messages:
    1,124
    Likes Received:
    265
    Occupation:
    Internet!
    Location:
    On the Interwebz
    Guys, I have a code that sort of works for circling people on Google+. Here it is:

    Code:
    EVENT TYPE=MOUSEDOWN SELECTOR="#contentPane>DIV>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV>DIV>DIV>DIV:nth-of-type(2)>DIV>DIV:nth-of-type(3)>DIV" BUTTON=0
    EVENT TYPE=MOUSEDOWN SELECTOR="#contentPane>DIV>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV>DIV>DIV>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV:nth-of-type(3)>DIV" BUTTON=0
    EVENT TYPE=MOUSEDOWN SELECTOR="#contentPane>DIV>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV>DIV>DIV>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV:nth-of-type(3)>DIV>DIV>DIV>DIV>DIV>SPAN" BUTTON=0
    TAG POS=1 TYPE=DIV ATTR=ROLE:presentation&&CLASS:b-P-Tb&&TXT:
    I got that from here - BHW. I don't remember where exactly.

    Anyway, the problem with the code is that sometimes my iMacro gets stuck when it comes to this, and also it's only effective about 50-60% of the times. Other times it sort of clicks something different on the page and so it never circles...

    Any chance someone can make a code that will work good and circle effectively?

    Here's a random profile you can test on...

    https://plus.google.com/+Wiederinc/posts
     
  2. Worm99

    Worm99 Power Member

    Joined:
    Jan 12, 2012
    Messages:
    548
    Likes Received:
    317
    Location:
    Multiverse
    Home Page:
    I had partial success with xyz click.
     
  3. Scorpion Ghost

    Scorpion Ghost Senior Member

    Joined:
    Mar 22, 2013
    Messages:
    1,124
    Likes Received:
    265
    Occupation:
    Internet!
    Location:
    On the Interwebz
    Yeah. I'd rather not use that. I need them to work universally for people.

    Thanks though.
     
  4. Scorpion Ghost

    Scorpion Ghost Senior Member

    Joined:
    Mar 22, 2013
    Messages:
    1,124
    Likes Received:
    265
    Occupation:
    Internet!
    Location:
    On the Interwebz
    Bump... long overdue... bump...
     
    • Thanks Thanks x 1
  5. donosla

    donosla Registered Member

    Joined:
    Sep 19, 2015
    Messages:
    63
    Likes Received:
    6
    any imacros for adding other peoples followers..?
     
  6. Scorpion Ghost

    Scorpion Ghost Senior Member

    Joined:
    Mar 22, 2013
    Messages:
    1,124
    Likes Received:
    265
    Occupation:
    Internet!
    Location:
    On the Interwebz
    So under the new Google+ platform/design, the button has become much easier to click. Using Experimental recording mode I can easily click that Follow button and do what I have to do.

    However, I've noticed that every 2-3 weeks the line that clicks the button in the iMacro stops working, and after recording that bit again, the new line is basically identical to the previous line, with a small difference. Always a small difference - a number, some text.

    And the problem is that because I have to use the Experimental recording mode in order to click that button successfully (otherwise it doesn't work with normal recording), I can't use the * in the iMacro which allows me to make the script disregard a particular number for example. The people that know how the * functions in iMacros will know what I'm trying to say.

    So, anyone knows how to use the * function in iMacro Experimental Recording mode? Or, anyone can record a line (not JavaScript) that will click the Follow button on Google+ pages, but that will work longer than a few weeks? Maybe it's possible with HTML recording mode or something.

    Let me know if anyone can help.?


    Just as an example. The following two lines:

    Code:
    EVENT TYPE=CLICK SELECTOR="#yDmH0d>C-HJKZNB>DIV:nth-of-type(5)>DIV>CONTENT>DIV>C-E1CI8B>DIV>DIV>DIV:nth-of-type(2)>DIV:nth-of-type(4)>DIV>DIV>CONTENT>SPAN>DIV>DIV" BUTTON=0
    
    EVENT TYPE=CLICK SELECTOR="#yDmH0d>C-WIZ>DIV:nth-of-type(5)>DIV>CONTENT>DIV>C-WIZ>DIV>DIV>DIV:nth-of-type(2)>DIV:nth-of-type(4)>DIV>DIV>CONTENT>SPAN>DIV>DIV" BUTTON=0
    So the first line was working last month, the second line is working at the moment this month. I expect it to stop working in about a week or two though.

    Hope someone can help with this...