1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

iMacros doesn't recognize facebook comment reply textbox and photo upload

Discussion in 'Other Scripting Languages' started by prosper109, Feb 27, 2014.

  1. prosper109

    prosper109 Junior Member

    Joined:
    Mar 3, 2013
    Messages:
    167
    Likes Received:
    13
    I've been trying to automate a process of replying to comments on facebook. I have iMacros click on the "Reply" button successfully, but when it comes to the comment reply itself or uploading a photo in the comment, it doesn't recognize the tag at all. I actually have to manually click on the comment or photo button once and cancel it, in order for facebook to change the html state of the input to something imacros sees. I don't know why this is happening.


    I've tried conventional recording mode without using ID selectors, i've also tried conventional recording with complete HTML tag, but the main issue is that it just doesn't see that comment section. I know how to code in javascript and imacros, so if a JavaScript solution is out there then that would help.
     
  2. Conor

    Conor Jr. VIP Jr. VIP

    Joined:
    Nov 7, 2012
    Messages:
    3,414
    Likes Received:
    5,522
    Gender:
    Male
    Location:
    South Africa
    Home Page:
  3. prosper109

    prosper109 Junior Member

    Joined:
    Mar 3, 2013
    Messages:
    167
    Likes Received:
    13
    I am using firefox.