1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I need 2 minutes help with SEO Yoast settings!

Discussion in 'Blogging' started by maildigger, Mar 21, 2017.

  1. maildigger

    maildigger Power Member

    Joined:
    Jan 30, 2009
    Messages:
    676
    Likes Received:
    86
    Location:
    EU
    I'm seeing that mediafiles are indexed by Google as a page.

    If I click this in Google I get a new page on my website with only the title of the picture + picture on it, check https://s2.postimg.org/rim4yiwih/example.png

    I have a page about "New York" http://www.website.com/new-york/ and I use a mediafile (picture) in this posts than this gets indexed like a page: http://www.website.com/new-york/mediafilename/

    I use "metarobots: index" for media.
    In my XML sitemap I 've put post + pages but I left media out.

    How do I fix this?
     
  2. Samwacgamchy

    Samwacgamchy Jr. VIP Jr. VIP

    Joined:
    Jan 11, 2017
    Messages:
    204
    Likes Received:
    41
    Gender:
    Female
    • Thanks Thanks x 1
  3. TrafficPop22

    TrafficPop22 Registered Member

    Joined:
    Mar 7, 2017
    Messages:
    86
    Likes Received:
    5
    good find i was looking for something like this
     
  4. darulez

    darulez Jr. VIP Jr. VIP

    Joined:
    Mar 12, 2013
    Messages:
    2,245
    Likes Received:
    694
    Gender:
    Female
    Occupation:
    Waiting 36 days till I can stick it in
    Location:
    Walhalla