1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to fx this Google Chrome bug?

Discussion in 'BlackHat Lounge' started by Sombrero, Aug 8, 2012.

  1. Sombrero

    Sombrero Senior Member

    Joined:
    Feb 28, 2011
    Messages:
    1,121
    Likes Received:
    861
    Occupation:
    Dogs love Christmas too ♥
    Location:
    Papal Island
    I'm browsing so happy and suddenly the following rare colors appear:

    [​IMG]

    I tried to unistall, erase all Chrome data, install beta version, and look for an update. I have to refresh the page and click the "X" at the top to see the website (it seems the bug can't load that way).

    Thanks!
     
  2. Sombrero

    Sombrero Senior Member

    Joined:
    Feb 28, 2011
    Messages:
    1,121
    Likes Received:
    861
    Occupation:
    Dogs love Christmas too ♥
    Location:
    Papal Island
    Anyone?
     
  3. rettaibi

    rettaibi Regular Member

    Joined:
    Jun 25, 2012
    Messages:
    440
    Likes Received:
    799
    dafuq never seen this before..
     
  4. Scripteen

    Scripteen Elite Member

    Joined:
    Sep 19, 2009
    Messages:
    1,811
    Likes Received:
    1,918
    Home Page:
    Happens with all the websites? Reset your theme to the default and see if this works.
     
  5. SonicSam

    SonicSam Registered Member

    Joined:
    Aug 21, 2012
    Messages:
    57
    Likes Received:
    5
    Location:
    X
    Could it be GPU acceleration gone bad?

    Google has the commands required to disable 2D GPU acceleration.

    chrome://flags/ has the following listed as selectable options


    Disable accelerated 2D canvas Mac, Windows, Linux, Chrome OS
    GPU compositing on all pages Mac, Windows, Linux

    Set both to disabled and try again after restarting Chrome?
     
  6. Sombrero

    Sombrero Senior Member

    Joined:
    Feb 28, 2011
    Messages:
    1,121
    Likes Received:
    861
    Occupation:
    Dogs love Christmas too ♥
    Location:
    Papal Island
    Must be that, I didn't think about it. Let's see!
     
  7. Sombrero

    Sombrero Senior Member

    Joined:
    Feb 28, 2011
    Messages:
    1,121
    Likes Received:
    861
    Occupation:
    Dogs love Christmas too ♥
    Location:
    Papal Island
    I will try that because the last solution didn't work! I still have the issue.
     
  8. CandyLand

    CandyLand Regular Member

    Joined:
    Apr 29, 2012
    Messages:
    212
    Likes Received:
    125
    Location:
    United Kingdom
    Crazy, this has been happening to me too for a few weeks. Doesn't depend on any particular website, but if I close the tab and reopen it, it's fine again. I'm sure the real fix is to abandon all google products...
     
  9. Endire

    Endire Elite Member Premium Member

    Joined:
    Mar 27, 2012
    Messages:
    1,756
    Likes Received:
    1,061
    Gender:
    Male
    Oh wow! not fun!

    I found this thread on the google chrome issues forum, and once you scroll allll the way down, someone at google has posted the following temporary fix:

    It may or may nor work for everyone:


    We have found easy steps to repro on two local machines. The good news is that the problem doesn't seem to exist post Chrome 21 (e.g. Dev channel (22) or Canary (23)). It repros pretty consistently by doing the following: 1. Turn on "compositing on all pages" in about:flags 2. Start the browser, go to www.google.com. 3. Open one more tab and once again go to www.google.com 4. Switch back to the first tab and close the second tab by clicking the corresponding red X button in the tab strip (without switching to it first). 5. At this point, the first tab will start showing the pattern. If it doesn't, click on the + next to the tab to open a new tab, and then switch back to the original one. This time it may be black (another manifestation of probably the same issue). Interestingly enough, this only happens when there's no horizontal scrollbar. Making the window small enough for the horizontal scrollbar to appear at the bottom seems to make the problem go away. Same thing is true if the FPS counter or the composited layer borders are shown. It seems to only be happening with integrated Intel GPUs and it looks most likely like a driver bug. We have a possible fix (a workaround really) that's being tested.

    ---

    Shawn
     
    • Thanks Thanks x 1
  10. Sombrero

    Sombrero Senior Member

    Joined:
    Feb 28, 2011
    Messages:
    1,121
    Likes Received:
    861
    Occupation:
    Dogs love Christmas too ♥
    Location:
    Papal Island
    There is not a solution in your reply but I got the same result as that guy! Thanks.
     
  11. Sombrero

    Sombrero Senior Member

    Joined:
    Feb 28, 2011
    Messages:
    1,121
    Likes Received:
    861
    Occupation:
    Dogs love Christmas too ♥
    Location:
    Papal Island
  12. ShadeDream

    ShadeDream Elite Member

    Joined:
    Nov 27, 2008
    Messages:
    2,209
    Likes Received:
    5,230
    Location:
    He who laughs last, laughs longest.
    I've got the best fix ever!

    Use a different browser.

    You're welcome.