1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Homepage doesn't appear when doinga site: search

Discussion in 'Black Hat SEO' started by rambolife, Jun 10, 2017.

  1. rambolife

    rambolife Regular Member

    Joined:
    Mar 15, 2012
    Messages:
    395
    Likes Received:
    53
    So I have a website that we bought in an auction a long time ago and did an overhaul of the design + content (it was parked before by the auction). I basically blasted the homepage with links and then a week ago everything was indexed but I could see the homepage when doing a site: search as the last result, which I thought wasn't a good sign.

    Now, when doing a site: search I can see it on page 3 out of 5. Still very awkward because all my other sites have the homepage as the first result when doing a site: search.

    Did this happen to anyone and what does it mean?
     
  2. Qool

    Qool Newbie

    Joined:
    Jun 9, 2017
    Messages:
    26
    Likes Received:
    6
    Do you have any reports in Google Search Console?
     
  3. rambolife

    rambolife Regular Member

    Joined:
    Mar 15, 2012
    Messages:
    395
    Likes Received:
    53
    I don't incorporate webmasters tool in the website.
     
  4. MikeyMikey13

    MikeyMikey13 Senior Member

    Joined:
    May 25, 2014
    Messages:
    1,048
    Likes Received:
    265
    Could be an algo penalty. I've had them a few times.

    Some come back, some don't. Wait a week and see.
     
  5. Nargil

    Nargil Jr. VIP Jr. VIP

    Joined:
    May 10, 2012
    Messages:
    3,997
    Likes Received:
    2,568
    Location:
    Europe
    Home Page:
    Well you blasted a homepage with links, not sure what you expected to happen. Could be both manual and algo penalty. Most likely algo though.
     
  6. JustCash

    JustCash Marketplace seller Marketplace seller Premium Member

    Joined:
    Jun 8, 2017
    Messages:
    111
    Likes Received:
    10
    Gender:
    Male
    Home Page:
    I've had this happen a few times. To be honest I'm not quite certain what it means, but it is some sort of lite penalty. A couple things I've done to correct it.
    - rewrite your copy, sometimes if you're copy seems duplicate or shitty google will do this
    - write more copy - sometimes theres just not enough content and google thinks the page is "thin"
    - just wait it out... the issue seems to correct itself after a few weeks in my experience