1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[HELP] WP-o-Matic -Yahoo Pipes - Hostgator

Discussion in 'Blogging' started by Deschen, Sep 3, 2009.

  1. Deschen

    Deschen Newbie

    Joined:
    Aug 26, 2009
    Messages:
    33
    Likes Received:
    8
    I'm trying to setup my first Autoblog but have run into an issue. Hope you will be able to help me.

    Wordpress :v 2.8.4
    WP-o-Matic 1.0RC4-6
    Hostgator Baby Croc


    Ok, so what I have is a blog I'm trying to create to pull feeds from various sources about a physical tech product (i.e: iphone).

    I have entered 2 RSS feeds, the first being the one from Yahoo Pipes (19 sources) and another one via AC

    I've done 2 modifications/patches that I have found via searching on this forums which is edit the wpomatic.php file as found in

    Code:
    hxxp://sudarmuthu.com/blog/2009/06/07/making-yahoo-pipes-feed-work-in-wp-o-matic.html
    as well as edit php my admin where i replaced

    &render=rss --> &_render=rss in the wp_wpo_campaign_feed feed table.

    as for the cronjob, i have tried both the default one given in the options tab as well as a variation i found in the following post
    Code:
    http://www.blackhatworld.com/blackhat-seo/blogging/109359-help-wp-o-matic.html
    I realise that by using the cron command given by WPO in cPanel X, the Standard Cron Manager will prompt me with Cron Updated!, but when I click on Go Back and Standard, the entry is not saved.

    Using the variation in the above post however, the cron command is saved.

    ------------

    INTERMISSION:

    sorry this description is messy and unorganised, i'm trying to organise my thoughts right now but i have spent the last 6 hours trying to fix this on my own and searching for the solution but have not been able to find it and my brain is totally fried. i just want to type out this probelm then crash and hopefully when i wake up i can continue with your helps...

    ------------

    OK, so now you are up to speed on what i have done. Moving on swiftly..
    in my WP Dashboard for WPO i can see from my logs that the variation cron is running according to schedule:

    September 4, 5: 02 am - Running cron job

    HOWEVER, after the cron job notification, the campaigns and feeds do not process. It is just stuck on Next! (PROBLEM 1)

    Next campaigns to process

    1. My 1st Campaign Next!

    Latest log entries


    • September 4, 5:36 am — Running cron job
    • September 4, 5:35 am — Running cron job
    • September 4, 5:34 am — Running cron job
    (set cronjob to run every 1 min for testing, will revert to every 1 hour before i sleep)


    when I attempt to fetch the campaigns manually, the feed for the Yahoo Pipe only works the first time it is added in WPO (PROBLEM 2). I find that now I need to delete the feed, add it again and then fetch for WPO to update my AUTO(my ass) Blog....


    sigh....ok, gonna sleep now. been at this forever. i think i am going to faint.

    love you guys (no gay)..., please help me! thank you.
     
    Last edited: Sep 3, 2009
  2. Deschen

    Deschen Newbie

    Joined:
    Aug 26, 2009
    Messages:
    33
    Likes Received:
    8
    anyone suggest a workaround?
    :)
     
  3. Nocali

    Nocali Newbie

    Joined:
    May 29, 2009
    Messages:
    41
    Likes Received:
    6
    I have the same problem with pipes.. They only get fetched the 1st few times pull them.
    I don't have a work around (wish i did) but this is a really annoying problem.
     
  4. Deschen

    Deschen Newbie

    Joined:
    Aug 26, 2009
    Messages:
    33
    Likes Received:
    8
    that sucks..for the amount of time spent trying to fix this i could have got a minimum wage job and paid someone to make 2 autoblogs for me....

    and i'm still stuck...might consider scrapping wp o matic all together and using something else to fetch the feeds or unpipeing my 18 feed sources and adding them individually but i dont know how stressful that will be on the server...

    dont fancy getting banned or anything..
     
  5. liam2003

    liam2003 Newbie

    Joined:
    Dec 18, 2009
    Messages:
    6
    Likes Received:
    1
    hey man when it comes to wp-o-matic, you need to edit the code slightly that you put into your cron jobs, at the start of the command put wget, so it will look like this

    (cron command) wget code..

    just remember to put that wget infron and it should auto fetch it