1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[HELP] “Invalid Redirect_uri:" FB APP

Discussion in 'General Scripting Chat' started by PersiaGrai, Apr 18, 2014.

  1. PersiaGrai

    PersiaGrai Registered Member

    Joined:
    Oct 20, 2013
    Messages:
    79
    Likes Received:
    8
    Good morning everyone,

    Okay I'm not a coder, i only have a really general understanding of it through 2nd hand experience, so i'll try to provide as much information as possible and hopefully someone can help with this.

    So i am using a service that requires users to connect an app on facebook to continue watching a video. Their website is called videosk.in. They give you the option to upgrade and after that you can use your own facebook app instead of theres so naturally i did it so i owned the information that came through. Also when you upgrade they allow you to use your own custom domains / sub domains. Here is where the problem lies:

    The app works fine, it prompts you to connect and everything but after the user does this, it doesnt redirect. The host service allows you to input a redirect url, no matter what you put in it it doesnt work. I know the app is capable of redirecting i'm using the same app with a different service as well and it works fine.

    My app domain: mywebsite.net , pushnotices.com
    Canvas URL: mywebsite.net/fb/
    Secure Canvas URL: https://pushnotices.com/fb/1932343749/
    (i didn't think that mattered since videoskn uses the website platform.)

    I've tried adding the website platform and filling in my domain as well as sub domains - doesnt work. I've tried doing the same thing except adding their domain - doesn't work. I've tried adding their domain as one of the app domains - doesn't work. There is nothing set in the "Valid OAuth redirect URIs", but i tried putting each of those links in there individually and then i get the 191 error that its not allowed and it has to be a domain or subdomain of something in the canvas url, secure canvas url or app domain sections (which it is).

    That's all the info i have access to, i'm not sure if its a problem within their actual site or not. Also, i'm not sure if this has anything to do with it, but that "Invalid Redirect_URI" error actually comes back in dutch, and then i translated it. The owner of Videoskin is dutch, so im guessing it has something to do with their site and not the app?

    I've talked to their coder and they're not sure yet either. If you need anymore info ill get it as quick as i can. I'd appreciate anything you guys can do to help!

    Bless.