1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Have I missed something?

Discussion in 'BlackHat Lounge' started by ezlegion, May 16, 2011.

  1. ezlegion

    ezlegion Senior Member

    Joined:
    Jun 22, 2010
    Messages:
    804
    Likes Received:
    292
    Location:
    UK
    Ok guys here goes:
    I have niche site with 20+ inner pages
    Some inner pages have hit #7 & #8 in serps with no backlinking and have 480+ exact searches pcm with low/medium comp
    homepage is targeted for 2 keywords, 1 high comp, 1 medium comp (the medium comp 1 has roughly same competition & searches as the inner pages mentioned above)

    Over the past 12 weeks I have thrown the following at the home page - all with linktext for main 2 keywords:
    In this order:
    25 ezine articles
    Roughly 25+ web 2.0's
    500+ pr4 profiles
    50+ .edu's
    10+ v high pr's
    roughly has 20+ tier 1 & 2's pointing to the above web 2.0's
    a number of the web 2.0's have had sb blasts of about 10K to them
    800+ private network blog posts
    300+ yahoo links
    50K sb blast - 25K to main page, 25K to inner pages

    As from 3 weeks ago I add 2/3 new articles a week to the site (to create more inner pages) and they seem to get indexed within hours

    I use senseo & firebug to help with any on page errors and on site optimization, also wordpress all in one seo - all that reads ok

    But the homepage will not budge from #25, every time a service kicks in it goes up for about a day. 1 time it hit #2, another time #11 and yesterday #10. But as regular as clockwork the homepage goes back to #25

    Now I must have hit some kind of filter but do you guys have any clues?
    :)
    To me it seems like g acknowledges the value of these new links, has a think about it then completely discounts them. I must have triggered some kind of filter but what I just can't work out
     
    Last edited: May 16, 2011
  2. KenB1

    KenB1 Junior Member

    Joined:
    May 14, 2011
    Messages:
    150
    Likes Received:
    34
    Location:
    104910
    Try a Kamehameha blast.
     
  3. jdog37

    jdog37 Power Member

    Joined:
    Apr 3, 2009
    Messages:
    510
    Likes Received:
    569
    Occupation:
    unemployed electrician
    Location:
    virginia
    Are you trying to build up your post count or are you just being a douchebag?

    Sorry OP. I don't know enough about it to help you but I do know enough not to post a stupid ass comment like KenB1 did.

    Maybe this will bump up the thread to get you some real advice from some helpful members here.
     
    • Thanks Thanks x 1
  4. ezlegion

    ezlegion Senior Member

    Joined:
    Jun 22, 2010
    Messages:
    804
    Likes Received:
    292
    Location:
    UK
    Thanks jdog - didn't bother replying to it myself lol:rolleyes:
     
  5. Bostoncab

    Bostoncab Elite Member

    Joined:
    Dec 31, 2009
    Messages:
    2,255
    Likes Received:
    514
    Occupation:
    pain in the ass cabbie
    Location:
    Boston,Ma.
    Home Page:
    ya seems odd you dumped that any links on it and didnt get a boost.

    I had an odd experience lately where I had been blasting links to http://site.com and the guy had his page set to default at www.site.com so the links were showing but not boosting as well as they should. I think you can do this in google webmaster tools.