1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google XML Sitemap Generator v3.2.4 & Wordpress v3.1.2

Discussion in 'White Hat SEO' started by Stu784, May 12, 2011.

  1. Stu784

    Stu784 Regular Member

    Joined:
    Nov 2, 2009
    Messages:
    426
    Likes Received:
    106
    Hi all,

    Has anyone else experienced issues with the plugin and this version of Wordpress?

    I've upgraded all of my existing sites to Wordpress v3.1.2 and set up a new blog this week however with the brand new blog I get these error messages when I try to build the site map:

    "There was a problem writing your sitemap file. Make sure the file exists and is writable.
    There was a problem writing your zipped sitemap file. Make sure the file exists and is writable."

    I've followed the advice on manually adding the sitemap.xml & sitemap.xml.gz files via FTP. Making the permissions writable (tried 755, 666 & 777) and trying to build the sitemap again and I'm still getting those errors.

    Other plugins I have installed at the moment are:

    Askimet
    All In One Seo
    Login Lockdown
    Ad Management - by Matt Crater (I'm also using his free theme however I removed the encrypted footer link)
    Contact Form 7
    Robots Meta
    Ultimate Google Analytics
    WP Tags to Technarati
    Yet Another Related Posts Plugin

    To try to get a sitemap built I deactivated 'Google XML Sitemap' & install 'BWP Google XML Sitemaps'

    This creates the sitemap showing no errors however when I try to visit the sitemap URL I get a blank white screen.

    Any help would be appreciated.
     
    Last edited: May 12, 2011
  2. bibirisca

    bibirisca Junior Member

    Joined:
    Dec 10, 2010
    Messages:
    137
    Likes Received:
    57
    Location:
    Transylvania
    Did you modified the .htaccess file?
    I had the same problems when I wrote a custom code in the .htaccess file.
     
  3. Stu784

    Stu784 Regular Member

    Joined:
    Nov 2, 2009
    Messages:
    426
    Likes Received:
    106

    No I didn't
     
  4. reinie

    reinie Elite Member

    Joined:
    Jan 16, 2009
    Messages:
    1,574
    Likes Received:
    1,040
    I had similar problem but it was fixed by deleting Global translator.
    Also, set your setting to 256M and "0"
     
  5. Chrisss

    Chrisss Senior Member

    Joined:
    Feb 22, 2011
    Messages:
    842
    Likes Received:
    172
    Location:
    BHW
    Sorry for off topic - but how did you remove the footer link?
     
  6. Stu784

    Stu784 Regular Member

    Joined:
    Nov 2, 2009
    Messages:
    426
    Likes Received:
    106
    Removal of encrypted footer link

    Code:
    http://themebot.com/tips-and-tutorials/how-to-remove-encrypted-footer-links-in-free-wordpress-themes
     
    • Thanks Thanks x 1
  7. Stu784

    Stu784 Regular Member

    Joined:
    Nov 2, 2009
    Messages:
    426
    Likes Received:
    106
    I can see where to add the 256M & 0 however I don't know how to delete the Global Translator.

    Is this a separate plugin or part of Google Sitemap Generator?
     
  8. Stu784

    Stu784 Regular Member

    Joined:
    Nov 2, 2009
    Messages:
    426
    Likes Received:
    106
    OK I've fixed this issue and found what was causing it.

    In General => Settings

    When I first built the site I changed trhe Blog Address (URL) to hxxp://www.website.c0m/ because I like the www. at the start.

    However I didn't change the Wordpress Address (URL) and left this as hxxp://website.c0m.

    I changed this so they both matched with the www. at the begining, reset all the settings in the settings page of Google XML sitemap and then rebuilt the sitemap and hey Presto everything is working.

    Hope this helps save anyone else some time if they have the same issue as I did.
     
  9. Chrisss

    Chrisss Senior Member

    Joined:
    Feb 22, 2011
    Messages:
    842
    Likes Received:
    172
    Location:
    BHW