1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google Keyword Tool "Download" Feature Not Working?

Discussion in 'Black Hat SEO' started by blakamia, Nov 28, 2012.

  1. blakamia

    blakamia Junior Member

    Joined:
    Jan 25, 2010
    Messages:
    162
    Likes Received:
    343
    Hi guys,

    Whenever I try to download keywords from the Google Keyword Tool, it immediately gives me an error, no matter what browser or IP address I use. Has Google banned me, or is this just an error on their side? Can someone please take 1 minute to test if they're getting the error?

    -blakamia
     
  2. gtree

    gtree Jr. VIP Jr. VIP Premium Member

    Joined:
    Dec 30, 2009
    Messages:
    1,158
    Likes Received:
    9,994
    Location:
    iN tHe FeEt Of My GuRu
    Home Page:
    Its working lol
     
  3. blakamia

    blakamia Junior Member

    Joined:
    Jan 25, 2010
    Messages:
    162
    Likes Received:
    343
    Well, the tool itself is working, but whenever I try to download a CSV from it it fails. Are you saying you can download the CSV without problems?

    -blakamia
     
  4. mahogany_rush

    mahogany_rush Newbie

    Joined:
    Mar 30, 2008
    Messages:
    11
    Likes Received:
    24
    Occupation:
    Mover and Shaker
    Location:
    A small town that sucks...
    I've been having the same problem for 2 days. When trying to download a CSV file of chosen keywords it returns "An Error Occured. Please Try Again Later". Very frustrating for sure...
     
  5. avi619

    avi619 Jr. VIP Jr. VIP

    Joined:
    Apr 1, 2012
    Messages:
    1,368
    Likes Received:
    1,883
    Location:
    Somewhere out there
    I am able to download .CSV .
     
  6. Aaric

    Aaric Elite Member

    Joined:
    Mar 7, 2010
    Messages:
    1,577
    Likes Received:
    1,120
    Gender:
    Male
    Location:
    USA
    some web blocker in browser.
     
    • Thanks Thanks x 1
  7. frazgta

    frazgta Power Member

    Joined:
    Jan 24, 2011
    Messages:
    574
    Likes Received:
    381
    I think its a connection issue. Sometimes doesn't work. Trying restarting your router.
     
  8. mahogany_rush

    mahogany_rush Newbie

    Joined:
    Mar 30, 2008
    Messages:
    11
    Likes Received:
    24
    Occupation:
    Mover and Shaker
    Location:
    A small town that sucks...
    It was a firefox issue... works fine in chrome. Why didn't I think of that... duh. :)