1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google doesn't index my domain but the domain it's not spammed

Discussion in 'Black Hat SEO' started by culling, Dec 15, 2016.

  1. culling

    culling Registered Member

    Joined:
    Apr 7, 2016
    Messages:
    79
    Likes Received:
    5
    Hello.
    On September I bought a domain that was indexed correctly on google and I was going to use it as PBN.
    I have planned many filler articles up today.

    Today I was going to drop my first external backlink to my money site. Before of that I did a research on google... and all the pages were missing.
    Any of filler articles I published during this months was indexed.
    So I added my site to a fake google webmaster account... And it's not spammed. It doesn't have any penalization at all.

    Something weird I notice though is that this PBN has 2.243 not found warning from the previous owner. This link are all .pdf files so I can't do much...

    Is this the cause? A build this site with Drupal and it's the first time I use this cms... Maybe I messed up something with this cms?
     
  2. Sristy

    Sristy Jr. VIP Jr. VIP Premium Member

    Joined:
    Aug 17, 2010
    Messages:
    1,839
    Likes Received:
    491
    Gender:
    Female
    Location:
    In My Blog Network
    Home Page:
    Google cannot find out a PBN before it was made a PBN. It is something else, check your robots.txt and .htaccess files to see if everything is setup properly and search engines are permitted to crawl your site.
     
  3. culling

    culling Registered Member

    Joined:
    Apr 7, 2016
    Messages:
    79
    Likes Received:
    5
    Yes I checked robots and htaccess of course and everything is ok...
    Using google webmaster tool I also tried to test how google see the site using his robots... and he can scan the page correctly...

    Also content I used as filler were the old articles of the past owner. And before publish them I checked that the articles wasn't copied somewhere alse... I lose a lot of time doing this...
     
  4. culling

    culling Registered Member

    Joined:
    Apr 7, 2016
    Messages:
    79
    Likes Received:
    5
    Any idea? I notice I lose some backlinks and now profile doesn't seems very good to me: TF: 13 CF: 25
    On September was much better
    What do you think? Should I give up on this domain?
     
  5. bartosimpsonio

    bartosimpsonio Jr. VIP Jr. VIP Premium Member

    Joined:
    Mar 21, 2013
    Messages:
    12,748
    Likes Received:
    11,413
    Occupation:
    COINZ
    Location:
    BUYAH
    Home Page:
    Got to the crawl page, and fetch as google. Submit page and linked pages for the root page /. You should see the root page indexed within 15 minutes and later you'll see all internal pages indexed.

    If you don't then there's something wrong.

    Check Drupal, maybe it's adding a header noindex, nofollow for some reason. On Wordpress if you tick "don't let search engines spider this site" it'll block engines. Maybe the same thing is available on Drupal.
     
    • Thanks Thanks x 1
  6. culling

    culling Registered Member

    Joined:
    Apr 7, 2016
    Messages:
    79
    Likes Received:
    5
    Thank you. I did fetch as google and now articles on homepage seems be indexed. But articles out of homepage are not yet indexed...
    Why this happened though?
     
  7. bartosimpsonio

    bartosimpsonio Jr. VIP Jr. VIP Premium Member

    Joined:
    Mar 21, 2013
    Messages:
    12,748
    Likes Received:
    11,413
    Occupation:
    COINZ
    Location:
    BUYAH
    Home Page:
    Maybe you had server downtime?

    The other links should be indexed within hours.

    Now monitor the site and see if goes awol again.
     
  8. seoways

    seoways Jr. VIP Jr. VIP

    Joined:
    Dec 19, 2009
    Messages:
    5,380
    Likes Received:
    805
    Gender:
    Male
    Location:
    MILKYWAY ;)
    Hi there

    Did you try submitting every single article in your site?
    Google takes no more than few minutes to crawl and get your site indexed. If the site is indexed after the submission, your inner pages (which contain articles) should also get indexed. I don't think your server could be down that time, since your homepage was indexed already, just try submitting all articles once again.
    That should work.

    Thanks