1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Damn.. Why is my site redirecting to another while I never did this?

Discussion in 'Black Hat SEO' started by bk071, Jul 7, 2011.

  1. bk071

    bk071 Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Nov 24, 2010
    Messages:
    3,104
    Likes Received:
    7,915
    Occupation:
    I don't have a job
    Location:
    .............
    I have a site

    Code:
    mycreditcardcompany.com
    (Yeah I don't care lol)

    And when you put up info:mycreditcardcompany.com in Google it displays

    Code:
    www.3lglobal.com
    When you go to
    Code:
    mycreditcardcompany.com
    you will notice that it loads fine and is not showing up any redirect whatsoever. But why the hell is google seeing it as a redirect?

    Anybody? I give up :D

    Cheers.
     
    • Thanks Thanks x 1
  2. other_henry

    other_henry Junior Member

    Joined:
    Jun 1, 2011
    Messages:
    107
    Likes Received:
    19
    Occupation:
    Freelance coder, server guy
    Location:
    US
    It looks like there was a redirect when you had a problem with your host:

    Code:
    https://encrypted.google.com/search?hl=en&as_q=info:mycreditcardcompany.com&as_epq=&as_oq=&as_eq=&num=10&lr=&as_filetype=&as_sitesearch=&as_qdr=all&as_rights=&as_occt=any&cr=&as_nlo=&as_nhi=&safe=images
    
       1.
          3LGlobal
          This account has been temporarily shut down. If you are the owner, please
          contact our accounting office.
          www.3lglobal.com/ - Cached - Similar
    
    
     
    • Thanks Thanks x 1
  3. the_demon

    the_demon Jr. Executive VIP

    Joined:
    Nov 23, 2008
    Messages:
    3,177
    Likes Received:
    1,563
    Occupation:
    Search Engine Marketing
    Location:
    The Internet
    ping your site so it updates in Google's index
     
    • Thanks Thanks x 1
  4. bk071

    bk071 Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Nov 24, 2010
    Messages:
    3,104
    Likes Received:
    7,915
    Occupation:
    I don't have a job
    Location:
    .............
    Thats not actually the issue... 3global.com is not even mine!

    I just want to know how can I remove the redirect... My .htaccess seems perfect!
     
  5. speedy5044

    speedy5044 Regular Member

    Joined:
    Jul 29, 2008
    Messages:
    456
    Likes Received:
    993
    Occupation:
    IM
    Check your htaccess or your cpanel if there is a redirection .
    BTW can you PM me the websites you're selling (im too lazy to PM lol)

    Edit: Im pretty sure its a redirection problem , even you check your page rank , its getting its own rank (PR3) from the other domain , you can fix this by removing the 301 redirection from your cpanel and (or) removing this line from your htaccess
    Code:
    rewriterule ^(.*)$ http://www.3global.com/$1 [r=301,nc] 
     
    • Thanks Thanks x 1
    Last edited: Jul 7, 2011
  6. SahL

    SahL Elite Member

    Joined:
    Jan 8, 2011
    Messages:
    1,594
    Likes Received:
    1,296
    Occupation:
    ★SEO expert and ★Sexpert
    Location:
    Bombay
    Home Page:
    if you are on shared Check your cpanel (redirects) option.

    There must be a re-direct somewhere.

    Post your .htacess here.
     
    • Thanks Thanks x 1
  7. other_henry

    other_henry Junior Member

    Joined:
    Jun 1, 2011
    Messages:
    107
    Likes Received:
    19
    Occupation:
    Freelance coder, server guy
    Location:
    US
    You are not being redirected, your server returns the correct 200 response code and your DNS settings look right.

    Google has old information about your domain, you need to get Google to update its information, you can't fix this on your server because there isn't a problem on your server.
     
    • Thanks Thanks x 1
  8. bk071

    bk071 Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Nov 24, 2010
    Messages:
    3,104
    Likes Received:
    7,915
    Occupation:
    I don't have a job
    Location:
    .............
    Here's my .htaccess file:

    And there are no redirects in cpanel either.

    Google is picking up my posts daily (http://www.google.com/#sclient=psy&...gc.r_pw.&fp=c306e119a7d85f91&biw=1024&bih=679)

    Not sure why its not updating the info:my........ thing. I've pinged the site multiple times and have also blasted in with SB! (~500 links in YSE)
     
  9. srb888

    srb888 Elite Member

    Joined:
    Jul 30, 2008
    Messages:
    3,260
    Likes Received:
    5,067
    Gender:
    Male
    Occupation:
    WebzSurfer
    Location:
    Sun, Mon, Tue, WTF, Sat!!! :)
    I think your site is not getting crawled by Google

    LOOK at these 2 items carefully:
    When I checked your site >>
    Code:
    http://web.archive.org/web/20081020025435/http://www.mycreditcardcompany.com/
    
    
                 [URL="http://wayback.archive.org/index.jsp"][IMG]http://staticweb.archive.org/images/logo_WM.png[/IMG][/URL]         
                                                                                        [CODE]http://mycreditcardcompany.com has been crawled 
    
    2 times going all the way back to July 5, 2008.
    [/CODE]
    Code:
    http://web.archive.org/web/20081020025435/http://www.mycreditcardcompany.com/
    [COLOR=Cyan]This account has been temporarily shut down            
    If you are the owner, please contact our accounting office[/COLOR]       


    The 1st result is for mycreditcardcompany(dot)com which is showing the correct site -- yours, and the next is for www(dot)mycreditcardcompany(dot)com which is that other site info.



    Looks very strange!


    Get your web host to look into this particular issue and they can resolve.


    HTH
     
    • Thanks Thanks x 1
    Last edited: Jul 7, 2011
  10. jerzydawg

    jerzydawg Supreme Member

    Joined:
    Dec 24, 2010
    Messages:
    1,260
    Likes Received:
    422
    This is like the only unsolvable question on BHW.
     
  11. SahL

    SahL Elite Member

    Joined:
    Jan 8, 2011
    Messages:
    1,594
    Likes Received:
    1,296
    Occupation:
    ★SEO expert and ★Sexpert
    Location:
    Bombay
    Home Page:
    The .htaccess seems Fine.

    Check other site files, for a redirect script or something.

    Also check your Domains settings (i dont think that can be done from there) but no harm in checking the records , if eveythings ok

    you've gotto contact the host, There might be some problem from thier side.
     
  12. speedy5044

    speedy5044 Regular Member

    Joined:
    Jul 29, 2008
    Messages:
    456
    Likes Received:
    993
    Occupation:
    IM
    Download all the website to your hard drive , then open notepad and use the find in files option to look for 3lglobal in the entire website folder , if you find it remove it and upload the edited files .
     
    • Thanks Thanks x 1
  13. srb888

    srb888 Elite Member

    Joined:
    Jul 30, 2008
    Messages:
    3,260
    Likes Received:
    5,067
    Gender:
    Male
    Occupation:
    WebzSurfer
    Location:
    Sun, Mon, Tue, WTF, Sat!!! :)
    Continuing from my earlier post:


    STRANGER RESULTS IN YAHOO!!!
    The other way around from the results shown in Google and Wayback>>


    Code:
    www(dot)mycreditcardcompany(dot)com shows:
    http://siteexplorer.search.yahoo.com/search?p=www.mycreditcardcompany.com&bwm=p&bwms=p&fr=moz35&fr2=seo-rd-se



    While mycreditcardcompany(dot)com show
    s:

    Code:
    http://siteexplorer.search.yahoo.com/search;_ylt=A0oG7zcnOhVOucQAe6fal8kF?p=mycreditcardcompany.com&y=Explore+URL&fr=sfp
    You are using httpS:// for mycreditcardcompany(dot)com and that is somehow conflicting with www(dot) sitename.
    Code:
    http://siteexplorer.search.yahoo.com/search;_ylt=A0oG7zcnOhVOucQAe6fal8kF?p=mycreditcardcompany.com&y=Explore+URL&fr=sfp
    
    See those 2 results for your site shown in the above link.




    Then, when I click on the httpS:// (secure) link shown in the above, I get this warning:





    --------- quote -------------------

    This Connection is Untrusted

    You have asked Firefox to connect
    securely to mycreditcardcompany(dot)com, but we can't confirm that your connection is secure.
    Normally, when you try to connect securely,
    sites will present trusted identification to prove that you are
    going to the right place. However, this site's identity can't be verified.


    What Should I Do?

    If you usually connect to
    this site without problems, this error could mean that someone is
    trying to impersonate the site, and you shouldn't continue.


    Technical Details:

    mycreditcardcompany
    (dot)com uses an invalid security certificate.

    The certificate is only valid for the following names:
    *.justhost
    (dot)com , justhost(dot)com

    (Error code: ssl_error_bad_cert_domain)


    --------- unquote -------------------


    I also think that you must have purchased the domain just recently and the site's history shows July 2008 as shown in my previous post. So the past owner must have used https for the site and it has carried over any conflicts when you redesigned the site after purchasing the domain.

    Just ask your host to resolve it.

     
    • Thanks Thanks x 2
    Last edited: Jul 7, 2011
  14. jon_xx_x

    jon_xx_x Jr. VIP Jr. VIP

    Joined:
    Nov 15, 2008
    Messages:
    3,100
    Likes Received:
    1,457
    Are your pages PHP?
    Log into FTP and see the files that were edited the latest.
     
  15. bk071

    bk071 Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Nov 24, 2010
    Messages:
    3,104
    Likes Received:
    7,915
    Occupation:
    I don't have a job
    Location:
    .............
    Checked. Nothing wrong with DNS and DS records.

    Thats a handy tip. Doing this right now!

    The it had an SSL certificate long ago but it is http://sitename which is redirecting to 3global. And when someone comes to my site then land on http:// unless they put https:// in their address bar themselves.

    Its a simple wordpress blog with nothing fancy like php whatsoever.

    Thanks for the responses, guys! Lets get this resolved :)
     
  16. bk071

    bk071 Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Nov 24, 2010
    Messages:
    3,104
    Likes Received:
    7,915
    Occupation:
    I don't have a job
    Location:
    .............
    I tried "find in files" but it got 0 hits in 0 files
     
  17. jon_xx_x

    jon_xx_x Jr. VIP Jr. VIP

    Joined:
    Nov 15, 2008
    Messages:
    3,100
    Likes Received:
    1,457
    Wordpress is PHP.
     
  18. bk071

    bk071 Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Nov 24, 2010
    Messages:
    3,104
    Likes Received:
    7,915
    Occupation:
    I don't have a job
    Location:
    .............
    Wordpress is written in php but it creates pages which are html.

    Anyway, I tried it and there are some files that were last modified back in 2010 and even 2008 but I'm sure thats fine and has nothing to do with this issue.
    index.php was modified in 2008
    wp-cron in 2010
    and so on

    I checked all my other WP blogs and the dates are same for all of them.
     
  19. jon_xx_x

    jon_xx_x Jr. VIP Jr. VIP

    Joined:
    Nov 15, 2008
    Messages:
    3,100
    Likes Received:
    1,457
    Check the template directory pages like header/footer etc?
    I don't know, I'm just guessing. I had a somewhat similar issue though, and they edited a bunch of my php pages and I didn't even know.
     
  20. bk071

    bk071 Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Nov 24, 2010
    Messages:
    3,104
    Likes Received:
    7,915
    Occupation:
    I don't have a job
    Location:
    .............


    Its being crawled by Google everyday.
    Code:
    http://webcache.googleusercontent.com/search?q=cache:5MzyGwMUoVsJ:www.mycreditcardcompany.com/+mycreditcardcompany.com&cd=1&hl=en&ct=clnk&source=www.google.com
    Last cache indexing was on 4th of July.