1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Custom permalinks not working anymore

Discussion in 'Blogging' started by hamma, Jul 17, 2010.

  1. hamma

    hamma Registered Member

    Joined:
    Feb 9, 2009
    Messages:
    67
    Likes Received:
    23
    Home Page:
    Hey everyone
    I haven't been able to get the custom permalink %catergory%/%postname% to work. If you use it and try and go to the post page it is 404.
    The only one of the other options that takes you to the post page correctly is the /2010/07/sample-post one all the others are 404 when you go to the post page. This is on a new istall with nothing else done? So if you haven't checked on any new blogs I would suggest you test them to make sure that they are working and giving you the seo benefits.
    Cheers Hamma
     
  2. wpbacklinks

    wpbacklinks Jr. VIP Jr. VIP Premium Member

    Joined:
    Mar 27, 2010
    Messages:
    3,399
    Likes Received:
    1,339
    Gender:
    Male
    Occupation:
    Affiliate Marketer
    Location:
    Everywhere
    did you mean wordpress? if so, you should write the code to .htaccess

    The following permalink rewrite code should be included in your .htaccess file:
    HTML:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    hope this help
     
  3. hamma

    hamma Registered Member

    Joined:
    Feb 9, 2009
    Messages:
    67
    Likes Received:
    23
    Home Page:
    Hi
    Yes I mean wp thanks for the fix. It used to work and you didn't need to add anything to make the custom permalinks go to the posts page so something has changed in wp
    Cheers