1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Content Lock Pro/Godaddy

Discussion in 'BlackHat Lounge' started by deeguy1, Feb 15, 2012.

  1. deeguy1

    deeguy1 Regular Member

    Joined:
    Mar 4, 2009
    Messages:
    204
    Likes Received:
    13
    Has anyone gotten Content Lock Pro to work with Godaddy or any other host other than Host Gator? If you have, and can help me get it working, I'm willing to pay.
     
  2. healzer

    healzer Jr. VIP Jr. VIP

    Joined:
    Jun 26, 2011
    Messages:
    2,701
    Likes Received:
    2,360
    Gender:
    Male
    Location:
    Somewhere in Europe
    Home Page:
    You have to request to enable a newer version of PHP I think
     
  3. deeguy1

    deeguy1 Regular Member

    Joined:
    Mar 4, 2009
    Messages:
    204
    Likes Received:
    13
    I selected PHP 5.3 on my hosting to start with, I'm stuck at this error: Site error: the file /xxx/xxx/xxx/xxx/xxx/xxx/index.php requires the ionCube PHP Loader ioncube_loader_lin_5.3.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.

    (I put x's in the place of my path)
     
  4. keinehabe

    keinehabe Supreme Member

    Joined:
    Nov 4, 2008
    Messages:
    1,207
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    -= CEO =-
    Location:
    Heaven
    Home Page:
    install the damn ioncube loaders then :) nothing to worry about it ( if you don't have ssh access to edit the php.ini files from your host then you have to get in touch with the support team from the hosting company ) ...
     
  5. T3chnician

    T3chnician Regular Member

    Joined:
    Oct 26, 2011
    Messages:
    278
    Likes Received:
    88
    I run it with godaddy, set up took me a few hours... install ioncube loader and you might run into one more issue that has to do with permissions I just cant remember. All I know is ur almost there for sure!!
     
  6. muxmkt

    muxmkt Power Member

    Joined:
    May 24, 2011
    Messages:
    548
    Likes Received:
    135
    add this to the .htaccess file

    Code:
    # Use PHP 5.3
    Action application/x-hg-php53 /cgi-sys/php53
    AddHandler application/x-hg-php53 .php 			 		
     
  7. deeguy1

    deeguy1 Regular Member

    Joined:
    Mar 4, 2009
    Messages:
    204
    Likes Received:
    13
    Thanks although I added that to the top of the file, then I just got a complete 404 error lol.



    Does anyone see anything wrong with my php5.ini file? (They told me to rename the php.ini file to php5.ini)



    register_globals = off
    allow_url_fopen = off

    expose_php = Off
    max_input_time = 60
    variables_order = "EGPCS"
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="


    ; Only uncomment zend optimizer lines if your application requires Zend Optimizer support

    [Zend]
    zend_optimizer.optimization_level=15
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3
    zend_extension=/usr/local/Zend/lib/Optimizer-3.3.3/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3/ZendExtensionManager_TS.so


    ; -- Be very careful to not to disable a function which might be needed!
    ; -- Uncomment the following lines to increase the security of your PHP site.

    ;disable_functions = "highlight_file,ini_alter,ini_restore,openlog,passthru,
    ; phpinfo, exec, system, dl, fsockopen, set_time_limit,
    ; popen, proc_open, proc_nice,shell_exec,show_source,symlink"

    zend_extension=/usr/local/Zend/lib/Guard-5.5.0/php-5.3.x/ZendGuardLoader.so

    [Zend]
    zend_extension=/home/content/43/8970743/html/ioncube/ioncube_loader_lin_5.3.so