1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't login to my WP blog anymore! WTF?!

Discussion in 'Blogging' started by xLoKuMx, Sep 16, 2009.

  1. xLoKuMx

    xLoKuMx Jr. VIP Jr. VIP Premium Member

    Joined:
    Jun 24, 2009
    Messages:
    173
    Likes Received:
    137
    Today morning I wanted to login to the wp-admin of my blog, but it didn't worked. Everytime I login it jumps back to the login screen in no time and the fields are empty again.
    I mailed me a new password, but it still doesn't work.
    Anyone can help me with this?

    I'm on Hostgator and installed the WP blog with Fantastico...
    This blog is about 3 weeks online, and I never had a problem till now!
     
  2. insider

    insider Regular Member

    Joined:
    Jul 5, 2009
    Messages:
    344
    Likes Received:
    134
    Location:
    Europe
    If you had version 2.8.3 or lower here is the answer http://www.milw0rm.com/exploits/9410

    Oops, didnt see "I mailed me a new password, but it still doesn't work."

    Well if you have access to the db you can try to reset it "by hand" yourself
     
  3. bluet

    bluet Junior Member

    Joined:
    Aug 15, 2008
    Messages:
    131
    Likes Received:
    16
    Have you try to use proxy? Usually i login with proxy when something bad happen
     
  4. sidddd

    sidddd Power Member

    Joined:
    May 15, 2008
    Messages:
    749
    Likes Received:
    460
    Hey,

    Go to PHP my admin and run the sql commands to retrieve the password and username from WP_users table.. or check wp_users file

    If it doesn't show anything then chances are your blog WP_users has been dropped/emptied.
     
    • Thanks Thanks x 1
  5. 44blackhatters

    44blackhatters Registered Member

    Joined:
    Jan 21, 2008
    Messages:
    52
    Likes Received:
    3
    Try to get into your database admin from hostgator. There you will find all of your wordpress set up functions. You should be able to change the password here and then login as normal.

    Good luck, you may have been hacked? Not sure. Consider upgrading your wordpress to avoid the security exploits.
     
  6. jovantot

    jovantot Newbie

    Joined:
    May 10, 2009
    Messages:
    2
    Likes Received:
    0
    this happens me once, so i tried to make may own php script to reset my own password and it works ofcourse, if you want pm me may be i can help you access your wp
     
  7. xLoKuMx

    xLoKuMx Jr. VIP Jr. VIP Premium Member

    Joined:
    Jun 24, 2009
    Messages:
    173
    Likes Received:
    137
    Thanks for all your answers, but nothing helped...

    • Mailing a password works fine, but I still can't login with the new one.
    • I changed username and password (md5) manually, still can't login.
    • Used Proxy, still can't login
    • Tried with FF and IE and cleard cache, cookies etc...still can't login.
    • renamed the plugin folder, still can't login.
    All that happens if I enter the right login info is a short loading time and then the login page again with no data in the form...no info or something else...

    If I enter a wrong login, there comes this pink box with wrong username.

    So my login and password must be right I think...

    I'm using the newest 2.8.4 WP and the frontend of the blog works perfect...no changes or anything...

    I have two other blogs on my hostgator and I can login without a problem.
     
  8. Hijinx

    Hijinx Junior Member

    Joined:
    Apr 13, 2009
    Messages:
    142
    Likes Received:
    87
    Location:
    New Jersey
    This happened to me once on a blog i purchased off some guy, he had the auto-upgrade plugin and it screwed up the login... At least thats what i thought might of happened, thought maybe that it might of been hacked as well.... heres what i did I to get mine to work...

    Backed up the DB, renamed the plugin folder and created a new one, renamed the theme i was using, checked the DB admin email to make sure it was still mine ;) re-uploaded all the WP files and checked folder permissions. Used the lost password thing, logged in...
     
  9. TwistedMarketing

    TwistedMarketing Regular Member

    Joined:
    Apr 18, 2008
    Messages:
    279
    Likes Received:
    113
    i am guessing its a "cookie" problem. Try logging in from any other browser or any other PC and see if this helps.
     
  10. xLoKuMx

    xLoKuMx Jr. VIP Jr. VIP Premium Member

    Joined:
    Jun 24, 2009
    Messages:
    173
    Likes Received:
    137
    I made a backup of the SQL database and reinstalled the blog!
    Everything works fine now. Wish I would know what the problem was...
    Thanks a lot for all your answers!
     
  11. tshin810

    tshin810 Junior Member

    Joined:
    Jun 16, 2009
    Messages:
    163
    Likes Received:
    668
    The problem is what ashley.2328 stated, the browser problem. I always got this problem. When it happened, I switch to other browsers :) Wordpress had this problem since years ago.

     
  12. xLoKuMx

    xLoKuMx Jr. VIP Jr. VIP Premium Member

    Joined:
    Jun 24, 2009
    Messages:
    173
    Likes Received:
    137
    This could be it...I'm running two scripts on my server...
    But as I said, my other two blogs on the same server had no problems...
     
  13. skyrain

    skyrain Registered Member

    Joined:
    Sep 16, 2009
    Messages:
    65
    Likes Received:
    62
    I had this happen and someone suggested some site that had a simple script to run. It worked and then I deleted the script... Let me see if I can find it, though!
     
  14. skyrain

    skyrain Registered Member

    Joined:
    Sep 16, 2009
    Messages:
    65
    Likes Received:
    62
  15. jkr500

    jkr500 Regular Member

    Joined:
    Apr 3, 2009
    Messages:
    239
    Likes Received:
    42
    Not sure but did you try to clear your cookies from your browser ? i know sometimes when you try to login to some websites sometimes they will not work but when you clear your cookies it will work again.
     
  16. xLoKuMx

    xLoKuMx Jr. VIP Jr. VIP Premium Member

    Joined:
    Jun 24, 2009
    Messages:
    173
    Likes Received:
    137
    I did it.
    Renamed plugins folder and created a new one.
    Deactivated all plugins in SQL...

    Yeah, I tried that...was the first thing I did after mailing me a new password...