1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can someone help me with a Cron job?

Discussion in 'BlackHat Lounge' started by ThePayRoll, Mar 23, 2011.

  1. ThePayRoll

    ThePayRoll BANNED BANNED

    Joined:
    Dec 1, 2010
    Messages:
    230
    Likes Received:
    86
    First off I'm using WPRobot.

    On my server, if I goto
    Code:
    http://site.com/wp-cron.php
    OR
    Code:
    http://www.site.com/wp-content/plugins/WPRobot3/cron.php?code=MYUNIQUECODE
    it processes the cron job(s) aka posts the posts for the campaigns.

    For some odd reason the "setup" within WPR isn't working.

    On the WPR support site I checked
    Code:
    http://wprobot.net/documentation/#94a
    It says to use this in the Cron job

    Code:
    wget	-O	/dev/null	http://www.yourdomain.com/wp-content/plugins/WPRobot3/cron.php?code=UNIQUECODE
    I replaces "yourdomain.com" with my domain and "UNIQUECODE" with my unique code. Placed it in the cron job and it said everything checked out fine. For the cron job report, everytime it's ran I have it report back to my email with the "log" i guess you could say. It says 404 Error(Document Not Found) I tried having the url "with wp robot" below:
    Code:
    http://www.yourdomain.com/wp-content/plugins/WPRobot3/cron.php?code=UNIQUECODE
    and I tried having the cron job goto
    Code:
    http://site.com/wp-cron.php
    Still get the 404 error.

    I talked to HostGator they said they can't do anything about it.
    I've went to BOTH the WPRobot URL and the wp-cron URL both are there and working just fine. But for some reason the Cron job isn't working properly or something. Yes I have wget enabled on the server, the tech's over at HG said that the cron job looks like it should be fine, and apparently it does. But for some reason it 'reports back' with a 404 error.

    And before any of you say it, yes I've posted on the WPRobot support forum, but no one has replied back except for one guy saying he has the same problem.
     
  2. artizhay

    artizhay BANNED BANNED

    Joined:
    Nov 21, 2010
    Messages:
    1,867
    Likes Received:
    1,335
    Try this instead:
    Code:
    /usr/bin/wget http://blahblahblah...