1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BlackHat CodeBreak script giving an error in Internet Explorer

Discussion in 'Cloaking and Content Generators' started by Wizzoid, May 14, 2009.

  1. Wizzoid

    Wizzoid Registered Member

    Joined:
    Dec 16, 2008
    Messages:
    94
    Likes Received:
    22
    Hi guys, please check the error below:

    [​IMG]

    The line in the script it's refering to:
    Code:
    var ul = document.createElement('ul');
        ul.style.textAlign = 'center';
        ul.style.margin = '0 0 10px 0';
        ul.style.padding = '0';
        ul.style.listStyleType = 'none';
        for(var i = 0;i<blocker_surveryLinks.length;i++){
            var li = document.createElement('li');        
            var a = document.createElement('a');
            a.style.display = 'block';
            a.style.fontSize = '14px';
            a.style.lineHeight = '22px';
            a.style.color = 'Blue';
            a.style.fontFamily = 'arial';
            a.style.textDecoration = 'underline';
            a.target = '_blank';        
            a.href = blocker_surveryLinks[i].url;
            a.innerHTML = blocker_surveryLinks[i].text;
            a.onclick = function(){
                window.setTimeout(unblockContent, 300000);
            }
            li.appendChild(a)    
            ul.appendChild(li);
        }
    In firefox the script is working fine, in IE i get the error. I'm seriously losing out on money because of this.

    Any help would be appreciated.
     
    Last edited: May 14, 2009
  2. Wizzoid

    Wizzoid Registered Member

    Joined:
    Dec 16, 2008
    Messages:
    94
    Likes Received:
    22
    Still struggling with this. I don't understand why IE is being a pain in the ass.
     
  3. Wizzoid

    Wizzoid Registered Member

    Joined:
    Dec 16, 2008
    Messages:
    94
    Likes Received:
    22
    SOLVED. My host was playing tricks with me. Changed hosting.
     
  4. Scotty

    Scotty Newbie

    Joined:
    Mar 9, 2009
    Messages:
    33
    Likes Received:
    9
    ur host happened to be hostgator?
     
  5. xxMP3xx

    xxMP3xx Regular Member

    Joined:
    May 19, 2009
    Messages:
    368
    Likes Received:
    46
    Location:
    <?php return 'CPU'; ?>
    Can you please alert about hosting, which hosting you were using buddy ?
     
  6. Wizzoid

    Wizzoid Registered Member

    Joined:
    Dec 16, 2008
    Messages:
    94
    Likes Received:
    22
    It wassn't the hosting that was the problem. When you use the codebreaker script, you can't add more than 3 links to it. If you do, it doesn't load the codebreaker script in IE anymore.
     
  7. boo blizzi

    boo blizzi Regular Member

    Joined:
    May 28, 2009
    Messages:
    361
    Likes Received:
    267
    i didnt use more than 3 links and i still cant get it to work in IE