1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Autoblog up for 2 months - but site not listed on google?

Discussion in 'Blogging' started by flame_copper, Jun 14, 2015.

  1. flame_copper

    flame_copper Registered Member

    Joined:
    Feb 12, 2010
    Messages:
    80
    Likes Received:
    1
    The search term itself has 13,900,000 results, the monthly search is about 13,100 with high competition, I got an exact domain with (keyword).com. Although I used some long tail keyword with 1000 search but got no results. Not even showing up on google.


    I have used plugin like:
    SEO Storecreator - to get the products from amazon
    WPRobot - to autopost products every 8 hours
    Social Media Feather - to have a social media button for every post
    SNAP - social network autoposter - post to twitter, delicious,tumblr, and related website.


    *In addition,
    I brought wiki page backlinks, 200 traffic per day from fiverr (not sure if this is good or not)

    Please advise.
     
  2. UptonGoodwin

    UptonGoodwin Power Member

    Joined:
    Jan 11, 2012
    Messages:
    593
    Likes Received:
    268
    It seems like your SEO strategy is about 5 years old. Autoblogs don't rank anymore without a lot of work. Not much weight goes toward having an exact match domain anymore either.
     
    • Thanks Thanks x 1
  3. Earned Results

    Earned Results Junior Member

    Joined:
    Jun 8, 2015
    Messages:
    104
    Likes Received:
    42
    Like UptonGoodwin said, Autoblogs don't work anymore. Dump that thing before you waste more time.
     
  4. Falcon11

    Falcon11 Newbie

    Joined:
    Jun 15, 2015
    Messages:
    23
    Likes Received:
    6
    I have a regular blog with good content and I can't even rank for my exact domain name. I didn't think it would be this difficult.