1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Are WP themes without hard links To Blog Posts bad for SEO?

Discussion in 'White Hat SEO' started by freckletone, Sep 20, 2015.

  1. freckletone

    freckletone Jr. VIP Jr. VIP

    Joined:
    Jul 22, 2009
    Messages:
    513
    Likes Received:
    82
    I'm talking about the new "fancy" themes like these that load via Ajax I believe...

    http://demo.mythemeshop.com/s/?theme=NewsPaper

    If you look at the source code the links to the blog posts aren't html coded like a href etc... but it's not visible in the source code?

    Can google still spider and crawl the blog post?
     
  2. nersande

    nersande Registered Member

    Joined:
    Jun 9, 2014
    Messages:
    74
    Likes Received:
    8
    Occupation:
    I blog for a living.
    Location:
    Germany
    You are looking at the demo site with features for seeing the theme.

    I run websites with themes from mythemeshop and they have normal links like any other template.
     
  3. freckletone

    freckletone Jr. VIP Jr. VIP

    Joined:
    Jul 22, 2009
    Messages:
    513
    Likes Received:
    82
    I'm using their Newspaper theme (the one i linked in the OP) one one of my sites and there are no hard links at all when I view the source.. it's invisible.

    I'm talking about their newer themes like "blogging" and "newspaper" ...

    The only hard links are to the category pages but not the blog posts... they are all loaded by ajax
     
  4. nersande

    nersande Registered Member

    Joined:
    Jun 9, 2014
    Messages:
    74
    Likes Received:
    8
    Occupation:
    I blog for a living.
    Location:
    Germany
    Are you using one of the endless loading layouts? That would be the only thing I can think of which would remove the reason to have normal links on the page.

    I usually remove that stuff since the readers are not on tumblr, and use normal pagination for pages - that might make the difference.
     
  5. freckletone

    freckletone Jr. VIP Jr. VIP

    Joined:
    Jul 22, 2009
    Messages:
    513
    Likes Received:
    82
    I set my pagination to "Default (Next / Previous)"..... so I think it is normal pagination? I didn't select the ajax options in my theme editor

    However when i view source there are still no hard links to blog posts and the titles of my blog posts are not in the source code... like if my blog post title was "the best skin care creams etc" it doesn't even show in the source code.

    I feel like it may affect SEO since this site is not ranking as well as my other sites. Hard to prove so maybe i will have to switch out the theme but i paid for it and like the slick design of it...

    I don't have this problem on my other sites using Mythemeshop's Splash theme which is more old school with hard links to blog posts...
     
  6. nersande

    nersande Registered Member

    Joined:
    Jun 9, 2014
    Messages:
    74
    Likes Received:
    8
    Occupation:
    I blog for a living.
    Location:
    Germany
    this still sounds really strange. I would mail the support about that question, that might be the easiest.
     
  7. bartosimpsonio

    bartosimpsonio Jr. VIP Jr. VIP Premium Member

    Joined:
    Mar 21, 2013
    Messages:
    12,476
    Likes Received:
    11,180
    Occupation:
    CHEAP
    Location:
    DATASETS
    Home Page:
    Won't matter. Googlebot is a headless browser. JS and ajax that pull content are also links.
     
  8. freckletone

    freckletone Jr. VIP Jr. VIP

    Joined:
    Jul 22, 2009
    Messages:
    513
    Likes Received:
    82
    oh this is weird; I found another site using my theme but their pages are all hard linked! They are ranking too! I obviously messed something up and have to go ask on mythemeshop forum :)
     
    Last edited: Sep 21, 2015