1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

All my web2.0s indexed but no link in GWT

Discussion in 'White Hat SEO' started by Scipio00, Aug 15, 2011.

  1. Scipio00

    Scipio00 Regular Member

    Joined:
    Dec 4, 2010
    Messages:
    443
    Likes Received:
    69
     
  2. exmortis512

    exmortis512 Registered Member

    Joined:
    Nov 17, 2010
    Messages:
    79
    Likes Received:
    61
     
  3. Xyz01

    Xyz01 Regular Member Premium Member

    Joined:
    Aug 8, 2011
    Messages:
    300
    Likes Received:
    126
    Give it time. Have you checked tools such as SEOMoz's open site explorer or Majestic SEO's backlink shower?
     
  4. Scipio00

    Scipio00 Regular Member

    Joined:
    Dec 4, 2010
    Messages:
    443
    Likes Received:
    69
    Yes, they got found some but where is the connection?
    I want that google cares about these backlinks, nott seomoz, majestic or yahoo...
     
  5. cash202

    cash202 Elite Member Premium Member

    Joined:
    Mar 12, 2011
    Messages:
    1,803
    Likes Received:
    2,823
    Location:
    Sydney, Australia
    Home Page:
    Only a very small number of your backlinks will ever appear in GWT. Forget
    about it. It is not a tool for backlink checking.
     
  6. jrbobdobbs

    jrbobdobbs Junior Member

    Joined:
    Jul 7, 2011
    Messages:
    116
    Likes Received:
    18
    What he said ^^

    I have this with my web 2.0s on a site - none even show up in Yahoo Explorer! But I know they are doing their job. There is no reliable backlink tool that can show them all for you, just have to live with it.