1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

affiliate links not working

Discussion in 'Black Hat SEO' started by mudbutt, Nov 15, 2010.

  1. mudbutt

    mudbutt Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Jun 23, 2010
    Messages:
    1,816
    Likes Received:
    4,284
    Location:
    ghosted
    Hey Im having an issue where I cannot view my affiliate links. Everytime I enter the afflink into the brower it shows up as

    Firefox can't establish a connection to the server at login.tracking101.com

    It does the same thing for Chrome and IE. The thing is, I've asked my affiliate manager and he said the links work for him. I asked my buddies to click it and they both said it works fine. However, I've been getting emails from LEADS that are saying my link is dead and that they went to the domain to get the product (thereby I lose my commissions). Does anyone else have this issue? Thanks.
     
  2. mudbutt

    mudbutt Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Jun 23, 2010
    Messages:
    1,816
    Likes Received:
    4,284
    Location:
    ghosted
    Last edited: Nov 15, 2010
  3. fulcanelli

    fulcanelli Jr. VIP Jr. VIP

    Joined:
    Jan 10, 2009
    Messages:
    247
    Likes Received:
    163
    Location:
    USA
    Some or most of your traffic is probably out of the US or whatever geographic area they are targeting.
     
  4. mudbutt

    mudbutt Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Jun 23, 2010
    Messages:
    1,816
    Likes Received:
    4,284
    Location:
    ghosted
    No, all targetting local leads. Its not just my traffic..I cant even click my own link on my own home IP california based.. I dont know what the problem is..its making me lose conversions lol.