Account suspended - high CPU / RAM usage

pokerente

Regular Member
Apr 12, 2010
347
100
Hi everybody,

I hosted my latest blog on hdwebprovider.com
It's using the regular SEO plugins and also some autoblogging scripts...
Today I found my website was blocked:

"Hello,

We had to suspend your account due to high CPU and RAM usage.
Currently the web site is using 98% of CPU and 91% of RAM.
Our limits are 20% of each resource.
Unfortunately we can't afford to host so large account on a shared server it affects other accounts. I strongly recommend you to consider upgrade to a dedicated server or limit your downloads.

Thank you."

Does anybody has any idea how I can limit that RAM/CPU usage or which scripts may cause the problem?

Thank you.
 
I would say it's most probably caused by one of your autobloging scripts,
Which one I couldn't tell as you haven't listed any. When you're running
more than a couple of autoblogs you're always better going for dedicated.
You could try making sure they're all posting at different times and not so often.
What is the spec of the server you're hosting on?
 
Last edited:
"What is the spec of the server you're hosting on?"

Sorry, don't understand this one.

I'm just hosting one blog there and fetching + autotranslating around 100 rss feeds a day. I could easily turn them off because I only use autoblog posts in order to get visited by the search engine bots. These posts don't show up for regular visitors, just through my own rss feed and by pinging them to technocr. and CO.

The main problem is that HDWEBPROVIDER doesn't react fast enough... I promised them to turn the scripts off since I don't really need them, but there has so far not been any reaction. I'm waiting now since an hour and they didn't respond to e-mails. F#CK, I'm doing a living from my websites and if they are suspended for more than a day I'm gonna lose my fu##ing rankings, get sites de-indexed and so on.

Absolutely unacceptable, normally the should first warn me and not suspend my whole account without even noticing me.
 
Yeah like I said... and probably another 100 in YouTube videos haha :D
However, these idiots didn't even warn me. Keep your hands off hdwebprovider.net :goodnight
 
I dont know what is causing the issue... deleted WP robot, wp o matic and so on... even the auto translator plugin and they still tell me RAM usage is too high..

ARGH!
 
I FOUND IT:

Automatic Translator plugin. Dammit, this was really fun, giving me around 50 indexed translated pages for one posting. Had to turn it off :-(
 
It sounds like they want only people that host a few pages and use little bandwidth.

Can you modify your plugins to spread the work out? Example, translate pages in small batches instead of all 50 pages at once?
 
LOL and now there's a database error. "
Error establishing a database connection


How I HATE this...
Anyone recommend a webspace provider where I can access my page normally, dont get banned because of scripts? I just want to work on my little blog. HDWEBPROVIDER does not seem to allow me :( Currently asking myself what exactly I paid them for.
 
It sounds like they want only people that host a few pages and use little bandwidth.

Can you modify your plugins to spread the work out? Example, translate pages in small batches instead of all 50 pages at once?

No, translation process works totally random. Can't control how many pages at one time. I guess there's a possibility to set that up by typing in the waiting time before translating another page... but currently it seems that it's not even the translator plugin but... i dont know, god or the devil.

I turned off ALL plugins and it still doesn't work :eek:
 
many autoblogging script/pluggin use many resource, especially if you have put so many url source for each task
 
You guys are comical.....

I pay 2 bucks a month and they shut me off because i was hogging the entire server resources - how unacceptable...

I hate to break it to you, but you're an idiot, plain and simple.

1) If you are making a living from your web site and are still using shared hosting - stop being a cheap ass and get a real solution - shared hosting has way too many variables and result in issues - ITS SHARED!

2) Stop blaming your web host for shutting your ass off, by your own admission you were running an ungodly amount of shit....wordpress by itself is a resource hog on a good day, add in a bunch of plugins running all day long and it uses even more.

See point #1.

3) Its shared hosting, you cant possibly think you can do whatever you want for you 2 bucks a month, if everyone did that they wouldn't be in business - you are naive to think anything but...

And to the point of using a reseller account, that won't get you anywhere whatsoever - the only thing you will be able to do is create your own web accounts, it is still SHARED and under the same restrictions.

Get a VPS (THIS IS STILL SHARED!!) or a dedicated server.

Alternative to a VPS is go cloud (VPS.NET) and you will be on shared machines but they self heal, VPS's do not is most all cases, you just simply renting a chunk on a machine.

Final comment, make freakin backups, your host goes down get your backup on a new server and get back online...
 
TurkeySub has some good points, stated more emphatically than I would, but true nonetheless. If you are truly making a living from these blogs, then allocate a portion of your income toward web resources.
 
Seems like your hoster isn't the best. They wouldn't just turn you off, but whatever. I doubt actually that 50 translation scripts can make such a high CPU usage.
 
"I'm just hosting one blog there and fetching + autotranslating around 100 rss feeds a day"
"Dammit, this was really fun, giving me around 50 indexed translated pages for one posting"


I cannot believe you wrote all that with a straight face. I wouldn't run that amount of crap on my dedicated servers (how do any visitors get a chance to use some RAM and CPU?) let alone a cheapo shared account. In fact it was other abusers like you that stopped me using shared hosting at all - too often I'd find my sites were unavailable for long periods of time to visitors because the server was constantly being locked up with badly set up autoblogging scripts hogging any available CPU cycles (and 100 feeds being autotranslated on one website is server abuse to the max).

Perhaps I've got out of the wrong side of the bed this morning but I cannot believe anyone's writing here supporting this. Anyway, back to my pit.
 
Back
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features and essential functions on BlackHatWorld and other forums. These functions are unrelated to ads, such as internal links and images. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock