1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A working youdigg.me bot

Discussion in 'Black Hat SEO' started by happybloger, Jan 21, 2010.

  1. happybloger

    happybloger Newbie

    Joined:
    Oct 24, 2009
    Messages:
    19
    Likes Received:
    6
    I found it hard and boring to click and click repeatedly at youdigg.me and decided to make a simple bot to automate the process. At first I tried some lame programs that monitor your mouse activity and then repeat it but that resulted in many bugs. Sometimes the page hadn't loaded sometime the digg it button was placed in a slightly alternate position etc...

    The I found the autohotkey scripting language and (as a junior programmer myself) managed to make a much more effective and fast script. It searches for the images and not just blindly click at a coordinate.

    The script is currently functional and I will improve when I have more spare time. (Exams period here :( )

    I uploaded the script to a simple blog with some instructions
    http://youdiggmebot.blogspot.com/
     
    • Thanks Thanks x 1
    Last edited: Jan 21, 2010
  2. cooolr

    cooolr Junior Member

    Joined:
    Jan 23, 2009
    Messages:
    116
    Likes Received:
    35
    Hey thank you very much.
    However the bot just closes itself (does not appear in the tray) and opens up your blogger website.

    Does this work on windows 7?
     
  3. happybloger

    happybloger Newbie

    Joined:
    Oct 24, 2009
    Messages:
    19
    Likes Received:
    6
    Damn, you are right. I will have it fixed and reupload it in no time.
     
  4. happybloger

    happybloger Newbie

    Joined:
    Oct 24, 2009
    Messages:
    19
    Likes Received:
    6
    Ok, download it again. I mistyped the variable name in the loop and it didnt work. The bot is supposed to open the developers bot when it finishes.

    In other words it is now FIXED

    Thx for pointing out my mistake so fast
     
    • Thanks Thanks x 1
  5. monsterclicks

    monsterclicks Jr. VIP Jr. VIP Premium Member

    Joined:
    Jul 1, 2009
    Messages:
    1,078
    Likes Received:
    714
    Home Page:
    Tried it . . . I enter in 100 and then it just closed (went to your blog).
     
    Last edited: Jan 21, 2010
  6. billymail01

    billymail01 Registered Member

    Joined:
    Jul 18, 2008
    Messages:
    63
    Likes Received:
    13
  7. happybloger

    happybloger Newbie

    Joined:
    Oct 24, 2009
    Messages:
    19
    Likes Received:
    6
    I check and recheck and recheck the code and everything is ok. It runs ok at my PC and suddenly I realise... You need the images in the same directory with the bot and I didnt upload them. Sorry again for the inconvinience, I will fix the links in the blog in a minute

    New Mediafire link : http://www.mediafire.com/file/nxzmkjorj3z/youdiggme.zip
     
  8. billymail01

    billymail01 Registered Member

    Joined:
    Jul 18, 2008
    Messages:
    63
    Likes Received:
    13
    Thanks, work now :)
     
  9. lhurey

    lhurey Newbie

    Joined:
    Sep 30, 2009
    Messages:
    46
    Likes Received:
    219
    after the bot clicks it shows and error and says you already dig this story. and the bot stop there.
     
  10. happybloger

    happybloger Newbie

    Joined:
    Oct 24, 2009
    Messages:
    19
    Likes Received:
    6
    This is probably a youdigg.me bug. If you hit the digg button and then click the no story here or navigate out of the site, next time you encounter the same digg you cant digg it and the "No story above button" doesnt do anything because the story exists.

    The bot might have click the No Story above button if your internet connection is slow and the browser didnt refresh the page on time when the bot hits the "Dugg. Take me to the next story" button.

    As I stated in my blog, the bot doesn't work correctly if you have a slow internet speed.

    I will implement a way for the bot to determine when a page has finished loading when I have some spare time. The bot waits for 15 seconds when it hits the "Dugg. Take me to the next story" button, if 15 seconds aren't enough for your pc and internet connection to load the page the bot will not function well.

    Keep providing me info about bugs and I will continue to improve the bot.

    If anyone needs a bot for a site that doesn't require captcha recognition just send me a pm. I might be able to help you if I am interested