1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

301 redirect - page still not inexed, but indexed in mobile

Discussion in 'White Hat SEO' started by auctionguy, Nov 15, 2014.

  1. auctionguy

    auctionguy Newbie

    Joined:
    Nov 13, 2014
    Messages:
    29
    Likes Received:
    6
    About a month ago I 301 redirected my forum's home page from /forum/ to /forum/index.php, because the pages were duplicates.

    Funny thing is, the old page is still showing in Google search results, but the new page was indexed in Google mobile results the first week.

    Both pages have a lot of high quality backlinks, the new page is listed in the site's navigation and the site has been crawled several times.

    I'm not quite sure what to make of this. Does anyone have any idea what could be causing this and is there a way to get Google to recognize & index the new page?
     
  2. ThopHayt

    ThopHayt Jr. VIP Jr. VIP Premium Member

    Joined:
    Jul 25, 2011
    Messages:
    5,396
    Likes Received:
    1,644
    If mobile is indexed that's not a bad sign. You could consider an indexing service but I'd recommend patience, don't do anything crazy and usually sites index naturally after time/traffic/links.
     
  3. auctionguy

    auctionguy Newbie

    Joined:
    Nov 13, 2014
    Messages:
    29
    Likes Received:
    6
    What do indexing services do? Do they just ping the site or do they create links to the pages?
     
  4. skyflash

    skyflash Jr. VIP Jr. VIP Premium Member

    Joined:
    Jan 28, 2014
    Messages:
    229
    Likes Received:
    32
    Most indexer services do Ping, as I guess you have nothing to worry and your 301 redirect will be updated soon and it might take some more time.
     
  5. auctionguy

    auctionguy Newbie

    Joined:
    Nov 13, 2014
    Messages:
    29
    Likes Received:
    6
    Okay, well I guess I'll just have to be patient. One other question about this:

    If Google hasn't indexed the new page, is it likely that the link juice from the old page isn't flowing to the new page yet?